Not able to generate Replicaset tag


[Detailed description of the issue or question]

I am using Percona operator for mongodb (1.15.0) (Mongodb 6) . I was trying to set a custom replicaset tag on one of the members . However , when i check rs.conf() , i do not see the new tags .

One of other the strange behaviour we witness is that after setting the replica set tag to null (which works sometimes) , the rs.conf shows the original tag.

Original replica set tag is as follows:
tags: {
podName: ‘my-cluster-name-rs0-3’,
serviceName: ‘my-cluster-name’

I tried setting the replicaset tag on my local (which is not on k8s) and it worked fine . My guess is Percona operator is resetting the tags .

Steps to Reproduce:

[Step-by-step instructions on how to reproduce the issue, including any specific settings or configurations]

  1. Login to database via an admin user (on primary)
  2. load config to a variable
    conf = rs.conf()
  3. Add tag to one of the members
    conf.members[2].tags = {“tag_testing” : “test”}
  4. Add the tag to the config
    rs.reconfig(conf,{force: true});
  5. Verify the replicaset tag


Mongodb version 6
Percona operator for Mongodb : 1.15.0


[If applicable, include any relevant log files or error messages]

Expected Result:

[What the user expected to see or happen before the issue occurred]

Actual Result:

[What actually happened when the user encountered the issue]

Additional Information:

[Include any additional information that could be helpful to diagnose the issue, such as browser or device information]

Hi, unfortunately it’s not possible to customize tags at the moment. If you need that feature, I suggest you open a request at

Hi @Ivan_Groenewold ,

Thank you for the update . I have raised the jira . Curious question though , was there any specific reason why custom tags are not allowed as of now ?

Thank you. Adding the link here for context [K8SPSMDB-1093] - Percona JIRA
No special reason, just that the operator uses its own tags and we don’t currently have a mechanism to customize them through yaml file/kubectl

Got it . Thanks again for the info . Appreciate it .