New install issue

I’m trying to do a clean install of Percona XtraDB cluster. I’m pretty much following this example to the letter:

At this location:

percona-webinars/percona-xtradb-cluster-installation-and-set up

(Won’t let me post links, silly thing)

It’s a brand new CentOS 6.2 machine, with no MySQL or other software installed yet.

I did a yum install of the percona packages, which worked just fine:

yum install Percona-XtraDB-Cluster-server Percona-XtraDB-Cluster-client Percona-Server-shared-compat percona-xtrabackupInstalled: Percona-Server-shared-compat.x86_64 0:5.5.29-rel29.4.401.rhel6 Percona-XtraDB-Cluster-client.x86_64 1:5.5.29- Percona-XtraDB-Cluster-server.x86_64 1:5.5.29- percona-xtrabackup.x86_64 0:2.0.5-499.rhel6 Dependency Installed: Percona-XtraDB-Cluster-galera.x86_64 0:2.0-1.143.rhel6

On the first node, I set up the config file pretty much just like the webinar showed. I added these to the my.cnf:

Innodb settings for percona/galerainnodb_locks_unsafe_for_binlog = 1innodb_autoinc_lock_mode = 2# percona xtradb cluster infowsrep_cluster_address=gcomm://wsrep_provider=/usr/lib64/libgalera_smm.sowsrep_slave_threads=4wsrep_cluster_name=pxctestwsrep_sst_method=xtrabackupwsrep_node_name=pxc1

I started mysql, which worked just fine, but when I ran the command to see the cluster size it shows 0, even though wsrep_ready shows “ON”:

mysql> show global status like ‘wsrep%’;±-------------------------±---------------------+| Variable_name | Value |±-------------------------±---------------------+| wsrep_cluster_conf_id | 18446744073709551615 || wsrep_cluster_size | 0 || wsrep_cluster_state_uuid | || wsrep_cluster_status | Disconnected || wsrep_connected | OFF || wsrep_local_index | 18446744073709551615 || wsrep_provider_name | || wsrep_provider_vendor | || wsrep_provider_version | || wsrep_ready | ON |±-------------------------±---------------------+

In the MySQL error log, it doesn’t really show an error, it just shows that its not loading any wsrep provider:

130204 21:33:32 [Note] WSREP: wsrep_start_position var submitted: '00000000-0000-0000-0000-000000000000:-1’130204 21:33:32 [Note] Plugin ‘FEDERATED’ is disabled.130204 21:33:32 InnoDB: The InnoDB memory heap is disabled130204 21:33:32 InnoDB: Mutexes and rw_locks use GCC atomic builtins130204 21:33:32 InnoDB: Compressed tables use zlib 1.2.3130204 21:33:32 InnoDB: Using Linux native AIO130204 21:33:32 InnoDB: Initializing buffer pool, size = 128.0M130204 21:33:32 InnoDB: Completed initialization of buffer pool130204 21:33:32 InnoDB: highest supported file format is Barracuda.130204 21:33:32 Percona XtraDB 1.1.8-rel29.1 started; log sequence number 1598129130204 21:33:32 [Note] Server hostname (bind-address): ‘’; port: 3306130204 21:33:32 [Note] - ‘’ resolves to ‘’;130204 21:33:32 [Note] Server socket created on IP: ‘’.130204 21:33:32 [Note] Event Scheduler: Loaded 0 events130204 21:33:32 [Note] WSREP: Read nil XID from storage engines, skipping position init130204 21:33:32 [Note] WSREP: wsrep_load(): loading provider library 'none’130204 21:33:32 [Note] /usr/sbin/mysqld: ready for connections.Version: ‘5.5.29’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona XtraDB Cluster (GPL), wsrep_23.7.1.r3843

As you can see, it shows:

[Note] WSREP: wsrep_load(): loading provider library ‘none’

The /usr/lib64/ file exists:

ls -oa /usr/lib64/ 1 root 2158520 Jan 30 17:36 /usr/lib64/

I’ve looked around, and I don’t see much information on whats going on here. Obviously I can’t move forward to get the rest of the nodes connected until I get past this.

Other things I’ve checked:

Firewall: none running
Conflicting ports: none
SELinux: disabled

Pretty much stuck here. Any help would be greatly appreciated!

Tried with the exact same rpms and my.cnf and it works fine. CentOS 6.3 but that shouldnt matter. Strange.

130205 23:40:09 [Note] WSREP: Read nil XID from storage engines, skipping position init130205 23:40:09 [Note] WSREP: wsrep_load(): loading provider library '/usr/lib64/’130205 23:40:09 [Note] WSREP: wsrep_load(): Galera 2.3(r143) by Codership Oy <> loaded succesfully.

Some googling suggests that you might be missing the openssl libs. What does ldd /usr/lib64/ say?

So what exactly was wrong with the path variable?

I have the similar situation.


$ ll /usr/lib/galera/
-rwxr-xr-x 1 root root 2188132 Mar 10 22:15 /usr/lib/galera/

WSREP: wsrep_load(): loading provider library ‘none’

I 2nd the question, how did you fix it?
I have the same issue!

WSREP: wsrep_load(): loading provider library ‘none’

Ok, I figured it out. There is a typo in the CentOS install instructions. The file needs to be /etc/my.cnf NOT /etc/my.conf.