loading provider library 'none'

I am trying to install an XtraDB Cluster server on my Mysql server. On this server I already have 3 MySQL (5.5) instances running with the mysql-multi script.
The server is a RedHat 6 Linux and I am using the dowloaded binaries from Percona. When I start the XtraDB Cluster instance, I get this message in the mysqld error log :
“…
130816 16:27:30 [Note] WSREP: Read nil XID from storage engines, skipping position init
130816 16:27:30 [Note] WSREP: wsrep_load(): loading provider library ‘none’
130816 16:27:30 [Note] /ccv/app/pxc55/bin/mysqld: ready for connections.
Version: ‘5.5.31-23.7.5-log’ socket: ‘/ccv/data/mysql/300/data/mysqld.sock’ port: 3336 Percona XtraDB Cluster (GPL) 5.5.31-23.7.5, Revision 438, wsrep_23.7.5.r3880
…”
This is what I added in my.cnf

###########################################################################

server 300 : Percona XtraDB Cluster TEST

###########################################################################

client = DINF/DSI/DSOL

application-1 = Typo3 VD.CH Production

application-2 =

application-3 =

application-4 =

web =

###########################################################################
[mysqld300]
user = mysql
basedir = /ccv/app/pxc55
mysqld = /ccv/app/pxc55/bin/mysqld_safe
mysqladmin = /ccv/app/pxc55/bin/mysqladmin
datadir = /ccv/data/mysql/300/data
pid-file = /ccv/data/mysql/300/data/mysqld.pid
log-error = /ccv/data/mysql/300/log/mysqld.err

port = 3336
socket = /ccv/data/mysql/300/data/mysqld.sock
skip-external-locking
key_buffer_size = 256M
max_allowed_packet = 36M
table_open_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
myisam_sort_buffer_size = 64M
thread_cache_size = 8

Query Cache is not supported with wsrep

query_cache_size = 24M

query_cache_type = 0
query_cache_size = 0

Try number of CPU’s*2 for thread_concurrency

thread_concurrency = 4

Replication Master Server (default)

binary logging is required for replication

log-bin = /ccv/data/mysql/300/log/bin-log

required unique id between 1 and 2^32 - 1

defaults to 1 if master-host is not set

but will not function as a master if omitted

server-id = 1

binary logging format - mixed recommended

ROW format recommended for Percona XtraDB Cluster

binlog-format = mixed

binlog-format = ROW

Point the following paths to different dedicated disks

tmpdir = /ccv/data/mysql/300/tmp
#log-update = /path-to-dedicated-directory/hostname

Uncomment the following if you are using InnoDB tables

innodb_data_home_dir = /ccv/data/mysql/300/data
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /ccv/data/mysql/300/log

You can set …_buffer_pool_size up to 50 - 80 %

of RAM but beware of setting memory usage too high

Voir plus loin: Config PXC

innodb_buffer_pool_size = 256M

innodb_additional_mem_pool_size = 20M

Set …_log_file_size to 25 % of buffer pool size

innodb_log_file_size = 64M

innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

default-storage-engine = INNODB
innodb_file_per_table

#Parametre Tuning
############################################################
character-set-server = utf8
collation-server = utf8_general_ci
max_allowed_packet = 32M
interactive_timeout = 288000
wait_timeout = 288000

transaction-isolation = READ-COMMITTED

############################################################

############################################################

Galera/Percona PXC Config Params

############################################################
wsrep_cluster_address=gcomm://
wsrep_provider=/ccv/app/pxc55/lib/libgalera_smm.so
wsrep_slave_threads=4
wsrep_cluster_name=pxctest
wsrep_sst_method=xtrabackup
wsrep_node_name=slv0116v-pxc
wsrep_sst_auth=“sstuser:S5tU53R”

log_slave_updates

innodb_locks_unsafe_for_binlog=1
innodb_autoinc_lock_mode=2
innodb_buffer_pool_size=400M
innodb_log_file_size=64M
############################################################

Of course, I already checked that the “wsrep_provider=/ccv/app/pxc55/lib/libgalera_smm.so” exists and is readable.
Can you tell me what I did wrong and need to correct ?

Thanks in advance.

It should work, can’t see any obvious mistake here. Looks like the wsrep_provider option is not passed to mysqld at all. Even if you put wrong file name, there should be this name in log entry, like this:

130801 4:24:09 [Note] WSREP: wsrep_load(): loading provider library '/usr/lib64/libgalera_smm.so1'
130801 4:24:09 [ERROR] WSREP: wsrep_load(): dlopen(): /usr/lib64/libgalera_smm.so1: cannot open shared object file: No such file or directory
130801 4:24:09 [ERROR] WSREP: wsrep_load(/usr/lib64/libgalera_smm.so1) failed: Invalid argument (22). Reverting to no provider.
130801 4:24:09 [Note] WSREP: Read nil XID from storage engines, skipping position init
130801 4:24:09 [Note] WSREP: wsrep_load(): loading provider library 'none'
130801 4:24:09 [ERROR] Aborting

So either the variable is not passed, or you don’t show all relevant error log entries, and there is some information earlier.

Btw. can you verify there is no SELinux problem? Check the [LEFT]/var/log/audit/audit.log for anything useful.
Also there is quite nice post about using mysql_multi with Galera based cluster: [/LEFT]
http://www.sebastien-han.fr/blog/201…s-with-galera/

Thank you for your suggestions,

SELinux is “disabled” and could not cause any problem.
I am still trying to find what is wrong.

I made some progress: “mysql_safe” did not transmit the wsrep parameters to “mysql”, so I changed in “my.cnf” :

mysqld = /ccv/app/pxc55/bin/mysqld_safe
to
mysqld = /ccv/app/pxc55/bin/mysqld

Now I can start the first node on my cluster. But any joiner node will crash with this message :

130822 15:20:27 [Note] WSREP: Running: ‘wsrep_sst_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’’
130822 15:20:27 [ERROR] WSREP: Failed to read 'ready ’ from: wsrep_sst_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’
Read: ‘Can’t find nc in the path’
130822 15:20:27 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role ‘joiner’ --address ‘10.120.148.45’ --auth ‘sstuser:S5tU53R’ --datadir ‘/ccv/data/mysql/300/data/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘3930’: 22 (Invalid argument)
130822 15:20:27 [ERROR] WSREP: Failed to prepare for ‘xtrabackup’ SST. Unrecoverable.
130822 15:20:27 [ERROR] Aborting

Seems like I am not the only one to have this problem. But I am still looking for a solution.

Can you please check if nc installed?

Please check it:
yum list installed | grep -i nc

If not then please install it:
sudo yum install nc

and try again

I have same problem with Black.Cap17. I try to install PXC with 3 database server. I always fail to start the cluster. I use Red Hat 6.6 64bit OS in those 3 servers.

mysql> show status like ‘wsrep%’;
±-------------------------±---------------------+
| Variable_name | Value |
±-------------------------±---------------------+
| wsrep_cluster_conf_id | 18446744073709551615 |
| wsrep_cluster_size | 0 |
| wsrep_cluster_state_uuid | |
| wsrep_cluster_status | Disconnected |
| wsrep_connected | OFF |
| wsrep_local_bf_aborts | 0 |
| wsrep_local_index | 18446744073709551615 |
| wsrep_provider_name | |
| wsrep_provider_vendor | |
| wsrep_provider_version | |
| wsrep_ready | ON |
±-------------------------±---------------------+
11 rows in set (0.00 sec)

Log produce :

150619 12:05:03 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
150619 12:05:03 mysqld_safe Skipping wsrep-recover for empty datadir: /var/lib/mysql
150619 12:05:03 mysqld_safe Assigning 00000000-0000-0000-0000-000000000000:-1 to wsrep_start_position
2015-06-19 12:05:03 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-06-19 12:05:03 0 [Note] /usr/sbin/mysqld (mysqld 5.6.24-72.2-56) starting as process 18838 …
2015-06-19 12:05:03 18838 [Note] Plugin ‘FEDERATED’ is disabled.
2015-06-19 12:05:03 18838 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-06-19 12:05:03 18838 [Note] InnoDB: The InnoDB memory heap is disabled
2015-06-19 12:05:03 18838 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2015-06-19 12:05:03 18838 [Note] InnoDB: Memory barrier is not used
2015-06-19 12:05:03 18838 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-06-19 12:05:03 18838 [Note] InnoDB: Using Linux native AIO
2015-06-19 12:05:03 18838 [Note] InnoDB: Using CPU crc32 instructions
2015-06-19 12:05:03 18838 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2015-06-19 12:05:03 18838 [Note] InnoDB: Completed initialization of buffer pool
2015-06-19 12:05:04 18838 [Note] InnoDB: Highest supported file format is Barracuda.
2015-06-19 12:05:04 18838 [Note] InnoDB: 128 rollback segment(s) are active.
2015-06-19 12:05:04 18838 [Note] InnoDB: Waiting for purge to start
2015-06-19 12:05:04 18838 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.24-72.2 started; log sequence number 1626291
2015-06-19 12:05:04 18838 [Note] RSA private key file not found: /var/lib/mysql//private_key.pem. Some authentication plugins will not work.
2015-06-19 12:05:04 18838 [Note] RSA public key file not found: /var/lib/mysql//public_key.pem. Some authentication plugins will not work.
2015-06-19 12:05:04 18838 [Note] Server hostname (bind-address): ‘*’; port: 3306
2015-06-19 12:05:04 18838 [Note] IPv6 is available.
2015-06-19 12:05:04 18838 [Note] - ‘::’ resolves to ‘::’;
2015-06-19 12:05:04 18838 [Note] Server socket created on IP: ‘::’.
2015-06-19 12:05:04 18838 [Note] Event Scheduler: Loaded 0 events
2015-06-19 12:05:04 18838 [Note] WSREP: Read nil XID from storage engines, skipping position init
2015-06-19 12:05:04 18838 [Note] WSREP: wsrep_load(): loading provider library ‘none’
2015-06-19 12:05:04 18838 [Note] /usr/sbin/mysqld: ready for connections.
Version: ‘5.6.24-72.2-56’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona XtraDB Cluster (GPL), Release rel72.2, Revision 1, WSREP version 25.11, wsrep_25.11
(END)

my.cnf content :

[mysqld]

port = 3306
socket = /var/lib/mysql/mysql.sock
datadir = /var/lib/mysql
skip-host-cache
skip-name-resolve
max_allowed_packet = 10485760

wsrep_provider = /usr/lib64/libgalera_smm.so
wsrep_cluster_address=gcomm://
binlog_format = ROW
default_storage_engine = InnoDB
innodb_autoinc_lock_mode = 2
wsrep_node_address = 192.168.10.2
wsrep_sst_method = xtrabackup
wsrep_cluster_name = emoney
wsrep_sst_auth = “percona:p3rc0n4”

Any suggestion ? Thanks before…

No user created. please read: https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/16043-node-shutdown-after-start?p=42689#post42689