Nagios object inheritance

Hi guys!

I followed the guide released by percona-Monitoring from here ->…=1468340962303

As mentioned in the guide, I have defined the required parameters in commands.cfg , hosts.cfg and services.cfg

Although, when I restart nagios (Nagios-core-v4), I get the error

" ========================================

Error: Template ‘mysql-host’ specified in host definition could not be not found (config file ‘/etc/nagios4/conf.d/hosts/rds_hosts.cfg’, starting on line 10) Error processing object config files!

" ========================================

I realised that I do not have the template “mysql-host” for it to be inherited.
I tried looking into the linux, windows and switches… It is using all inheriting different templates and tried looking for these templates but wasn’t able to find any of it.
Could somebody please help in figuring out these generic templates, where they are located and how I can get the mysql-host template in order for it to be inherited and work successfully.

My config files

  1. rds-host.cfg -->
  2. rds-services.cfg -->
  3. rds-command.cfg -->

Thanks in advance!

Case Resolved. Please close this thread.