mysql server crashes on archive table

Server version: 5.5.44-0+deb7u1 (Debian) on raspberry pi.
In this server an ARCHIVE table with 5.635.816 records.
After a recent addition I tried an ‘optimize’ step:

ERROR 2013 (HY000): Lost connection to MySQL server during query
mysql> describe table p1_archive;
ERROR 2006 (HY000): MySQL server has gone away
No connection. Trying to reconnect…

This server-side crash consistently happens since then, on every optimize table, check table, on select … into outfile, on mysqldump.
On running mysqldump with where clause I succeed in grabbing about 2.700.000 records into the dumpfile from all 5.635.816 in the table, before this server-crash happens.
pt-archive does not run: Cannot find an ascendable index in table…

Any suggestions as to how to recover the remainder?

Thanks in advance for any suggestion.

Just tried mysqldbexport from mysql-utilities. Here mysqldbexport is killed by the kernel with ‘out-of-memory’ message while processing the archive table:

Aug 30 21:11:48 pibrev20 kernel: [70075.579503] Out of memory: Kill process 4542 (mysqldbexport) score 495 or sacrifice child
Aug 30 21:11:48 pibrev20 kernel: [70075.579531] Killed process 4542 (mysqldbexport) total-vm:252988kB, anon-rss:243552kB, file-rss:676kB

looks asif the data-to-export is build in memory before writing it to file.
Any suggestions how to tune the export process, my archive-table and/or my server to prevnt this behaviour?