Orphaned table space after optimize lock up

During a nightly OPTIMIZE TABLE mysql seemed to have got hung up while optimizing the table.
Someone kill -9 mysqld and restarted the server. Now we have this stuck tablespace(?) that we
can’t seem to get rid of. We have tried following instructions here: http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshootin g-datadict.html
but nothing seems to work. I also tried dropping the database which caused MySQL to crash
and restart. It generated a back trace and some other stuff in the logs:

Thread pointer: 0x92c3278
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong…
stack_bottom = ffffffffa84ec36c thread_stack 0x30000
/usr/sbin/mysqld(Z24plugin_foreach_with_maskP3THDPFcS0_P13s t_plugin_intPvEijS3+0x19a)[0x81bde0a]
/usr/sbin/mysqld(_Z21mysql_execute_commandP3THD+0x3468)[0x81 b19e8]
/usr/sbin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x36 9)[0x81b5059]
/usr/sbin/mysqld(_Z16dispatch_command19enum_server_commandP3 THDPcj+0x1968)[0x81b6a58]
/usr/sbin/mysqld(_Z24do_handle_one_connectionP3THD+0xe5)[0x8 25b195]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (92c5758): drop database voicemail
Connection ID (thread ID): 3

mysql> select * from INFORMATION_SCHEMA.INNODB_SYS_TABLES WHERE name like ‘#%’;
±---------±----------------±------------±-----±-------+ -------+
±---------±----------------±------------±-----±-------+ -------+
| 47 | voicemail | #sql2-af6-2 | 1 | 11 | 44 |
±---------±----------------±------------±-----±-------+ -------+

This seems like a bug in some regards. The only think I can think of at this point to get
rid of this orphan is to completly blow out mysql and restore from backups. We are using
one file per table. Any help would be appreciated.

Running Percona-Server-server-55-5.5.27-rel28.0.291.rhel5


Does this seem like a bug in mysql?

Do you have userstats enabled? If so, can you try disabling it? This is to rule out https://bugs.launchpad.net/percona-server/5.5/+bug/1011047