Mongod Service is not running after adding the authorization

I have deployed the MongoDB Replica Set Cluster on the GCP VM’s.

Enabled the TLS for the cluster.

Followed the procedure for enabling the authorization from the documentation


If i restart the mongod service then it’s not running and throwing the below error

High-performance, schema-free document-oriented database
Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2024-03-29 09:07:53 UTC; 10s ago
Process: 1796611 ExecStartPre=/usr/bin/ (code=exited, status=0/SUCCESS)
Process: 1796643 ExecStart=/usr/bin/env bash -c ${NUMACTL} /usr/bin/mongod ${OPTIONS} > ${STDOUT} 2> ${STDERR} (code=exited, status=2)

 systemd[1]: Starting High-performance, schema-free document-oriented database...
 systemd[1]: mongod.service: Control process exited, code=exited, status=2/INVALIDARGUMENT
 systemd[1]: mongod.service: Failed with result 'exit-code'.
 systemd[1]: Failed to start High-performance, schema-free document-oriented database

Can someone need to help on this


Hi Ram,

Welcome to Percona Community Forum.

The error you are getting could be because of several reasons.

Could you please share errors from MongoDB logs? This will help us to identify the actual issue