max_connections setting my my.cnf does not work

I am using Percona Server 5.7 on my VPS, and I have an issue with the setting of max_connections is the config file. The default value is 151, and I wanna increase it to 200. I can do it simply by running this query on the mysql command line:set GLOBAL max_connections = 200;  # even I can set it to 500 without any issue in the command line.But when it comes to the configuration file, it does not work. Even I am unable to set it to 152. I edited this file on my CentOS 8 machine: /etc/my.cnf.d/mysql.What is wrong with my config file?

I added the following settings to my.cnf, still no chance:table_open_cache = 8000
innodb_file_per_table = 1
open-files-limit = 8192

I found the issue, I should set the values in /etc/percona-server.conf.d/mysqld.cnf, while I was saving them in /etc/my.cnf.d/mysql.cnf.