Installing proxysql2 on centos7 with percona-xdbcluster 5.7

Trying to install proxysql2.0

[root@cldb04mercury etc]# yum install proxysql2
Loaded plugins: enabled_repos_upload, langpacks, package_upload, product-id, search-disabled-repos, subscription-manager
iconectiv_epel_7_Extra_Packages_for_Enterprise_Linux_7_-_x86_64 | 2.8 kB 00:00:00
rhel-7-server-rpms | 2.0 kB 00:00:00
rhel-7-server-satellite-tools-6.5-rpms | 2.1 kB 00:00:00
Resolving Dependencies
–> Running transaction check
—> Package proxysql2.x86_64 0:2.0.7-1.2.el7 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

proxysql2 x86_64 2.0.7-1.2.el7 percona-release-x86_64 8.9 M

Transaction Summary

Install 1 Package

Total size: 8.9 M
Installed size: 8.9 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : proxysql2-2.0.7-1.2.el7.x86_64 1/1
Uploading Package Profile
Loaded plugins: langpacks, product-id, subscription-manager
Loaded plugins: langpacks, product-id, subscription-manager
Loaded plugins: langpacks, product-id, subscription-manager
Verifying : proxysql2-2.0.7-1.2.el7.x86_64 1/1

proxysql2.x86_64 0:2.0.7-1.2.el7

Uploading Enabled Repositories Report
Loaded plugins: langpacks, product-id, subscription-manager
[root@cldb04mercury etc]# service proxysql2 start
Redirecting to /bin/systemctl start proxysql2.service
Failed to start proxysql2.service: Unit not found.
[root@cldb04mercury etc]# service proxysql start
Redirecting to /bin/systemctl start proxysql.service
[[COLOR=#FF0000]root@cldb04mercury etc]# proxysql-admin --proxysql-username=admin --proxysql-hostname=localhost --enable
ERROR 2003 (HY000): Can’t connect to MySQL server on ‘localhost’ (111)
ERROR (line:713) : ProxySQL connection check failed.
– Could not connect to ProxySQL at localhost:6032
– Please check the ProxySQL connection parameters and status.
[root@cldb04mercury etc]#

Any ideas… pxc-cluster 5.7 is installed and running…

Issue was with local firewall

Thanks for the update, Mike, appreciated. It might help someone else down the line.