Installation failing on RHEL 7.2

I tried to follow the instructions at https://www.percona.com/doc/percona-xtrabackup/2.4/installation/yum_repo.html to install on RHEL 7.2.





$ yum list
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Repo rhel-7-workstation-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/8253033614287909731-key.pem
http://repo.percona.com/release/7Workstation/RPMS/noarch/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn’t help to resolve this issue please open a ticket with Red Hat Support.

One of the configured repositories failed (Percona-Release YUM repository - noarch),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

  1. Contact the upstream for the repository and get them to fix the problem.

  2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

  3. Disable the repository, so yum won’t use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    –enablerepo for temporary usage:

yum-config-manager --disable percona-release-noarch

  1. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

yum-config-manager --save --setopt=percona-release-noarch.skip_if_unavailable=true

failure: repodata/repomd.xml from percona-release-noarch: [Errno 256] No more mirrors to try.
http://repo.percona.com/release/7Workstation/RPMS/noarch/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found



For the URL that is failing, it seems that the directory '7Workstation' does not exist. Sure would be nice if this just worked!

What I did instead: I found package 'percona-xtrabackup.x86_64' in the EPEL repositories (which at the time of writing installed version 2.2) and installed like this: