Installation error for 2.4.5

Hi,

I tried to install, but get error below. Any information would be appreciated. Thanks in advance.
I use Ubuntu 16.04

sudo dpkg -i percona-xtrabackup-dbg-24_2.4.5-1.xenial_amd64.deb
[sudo] password for wjiang:
Selecting previously unselected package percona-xtrabackup-dbg-24.
(Reading database … 315406 files and directories currently installed.)
Preparing to unpack percona-xtrabackup-dbg-24_2.4.5-1.xenial_amd64.deb …
Unpacking percona-xtrabackup-dbg-24 (2.4.5-1.xenial) …
dpkg: dependency problems prevent configuration of percona-xtrabackup-dbg-24:
percona-xtrabackup-dbg-24 depends on percona-xtrabackup-24 (= 2.4.5-1.xenial); however:
Package percona-xtrabackup-24 is not installed.

dpkg: error processing package percona-xtrabackup-dbg-24 (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
percona-xtrabackup-dbg-24

sudo dpkg -i percona-xtrabackup-dbg-24_2.4.5-1.xenial_amd64.deb
(Reading database … 315420 files and directories currently installed.)
Preparing to unpack percona-xtrabackup-dbg-24_2.4.5-1.xenial_amd64.deb …
Unpacking percona-xtrabackup-dbg-24 (2.4.5-1.xenial) over (2.4.5-1.xenial) …
dpkg: dependency problems prevent configuration of percona-xtrabackup-dbg-24:
percona-xtrabackup-dbg-24 depends on percona-xtrabackup-24 (= 2.4.5-1.xenial); however:
Package percona-xtrabackup-24 is not installed.

dpkg: error processing package percona-xtrabackup-dbg-24 (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
percona-xtrabackup-dbg-24

Are you really trying to install the debug version of percona-xtrabackup? If so then you need to install the standard first. Otherwise just download the non-debug version and try again.

Hi Jrivera,

My mistake to install debug version…
I successfully install the standard version, but got an error when I run the backup:
Unrecognized character \x01; marked by <-- HERE after <-- HERE near column 1 at - line 1374

At the end, “completed OK!” did show up.
Can I ignore the error?


Unrecognized character \x01; marked by <-- HERE after <-- HERE near column 1 at - line 1374.
170322 19:12:31 Connecting to MySQL server host: localhost, user: choreer, password: set, port: not
set, socket: not set
Using server version 5.7.17-0ubuntu0.16.04.1
innobackupex version 2.4.6 based on MySQL server 5.7.13 Linux (x86_64) (revision id: 8ec05b7)
xtrabackup: uses posix_fadvise().
xtrabackup: cd to /var/lib/mysql
xtrabackup: open files limit requested 0, set to 1024
xtrabackup: using the following InnoDB configuration:
xtrabackup: innodb_data_home_dir = .
xtrabackup: innodb_data_file_path = ibdata1:12M:autoextend
xtrabackup: innodb_log_group_home_dir = ./
xtrabackup: innodb_log_files_in_group = 2
xtrabackup: innodb_log_file_size = 50331648
InnoDB: Number of pools: 1
170322 19:12:31 >> log scanned up to (7186164)
xtrabackup: Generating a list of tablespaces
InnoDB: Allocated tablespace ID 21 for sys/sys_config, old maximum was 0
170322 19:12:32 [01] Copying ./ibdata1 to /aceletBackup/mysqlBackup/db/ibdata1
170322 19:12:32 >> log scanned up to (7186164)
170322 19:12:33 >> log scanned up to (7186164)
170322 19:12:34 [01] …done

170322 19:12:51 [00] Writing xtrabackup_info
170322 19:12:51 [00] …done
xtrabackup: Transaction log of lsn (7186155) to (7186164) was copied.
170322 19:12:51 completed OK!

Can you run with --no-version-check, in any case the error is harmless.

The error is gone with --no-version-check. Good.
Thanks.