xtrabackup 1.3 broken?

I just tried an xtrabackup 1.3 run and it fails. Downgrading to 1.2 using the same command results in a successful backup. I’m using the x86_64 deb packages from the percona site on Ubuntu Jaunty and Lucid (stock MySQL packages), same results on both. Here’s the output from a failed run:

/usr/bin/innobackupex-1.5.1 --user=root --password=password --ibbackup=/usr/bin/xtrabackup --slave-info --stream=tar --throttle=250 --tmpdir=/var/backup/xtrabackuptmp /var/backup/xtrabackup+ gzip --stdout --best --rsyncable -qVersion string ‘’ contains invalid data; ignoring: ‘’ at /usr/bin/innobackupex-1.5.1 line 1637.InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy.All Rights Reserved.This software is published underthe GNU GENERAL PUBLIC LICENSE Version 2, June 1991.IMPORTANT: Please check that the backup run completes successfully. At the end of a successful backup run innobackupex-1.5.1 prints “completed OK!”.innobackupex-1.5.1: Using mysql Ver 14.12 Distrib 5.0.75, for debian-linux-gnu (x86_64) using readline 5.2innobackupex-1.5.1: Using mysql server version Copyright © 2000-2008 MySQL ABinnobackupex-1.5.1: Created backup directory /var/backup/xtrabackup100716 13:03:53 innobackupex-1.5.1: Starting mysql with options: --password=password --user=root --unbuffered --100716 13:03:53 innobackupex-1.5.1: Connected to database with mysql child process (pid=1150)100716 13:04:01 innobackupex-1.5.1: Connection to database server closed100716 13:04:01 innobackupex-1.5.1: Starting mysql with options: --password=password --user=root --unbuffered --100716 13:04:01 innobackupex-1.5.1: Connected to database with mysql child process (pid=1160)100716 13:04:05 innobackupex-1.5.1: Connection to database server closed100716 13:04:05 innobackupex-1.5.1: Starting ibbackup with command: xtrabackup_50 --backup --suspend-at-end --log-stream --target-dir=./ --throttle=250innobackupex-1.5.1: Waiting for ibbackup (pid=1166) to suspendinnobackupex-1.5.1: Suspend file '/var/lib/mysql/xtrabackup_suspended’innobackupex-1.5.1: Error: ibbackup child process has died at /usr/bin/innobackupex-1.5.1 line 480.

There’s also a warning about the version string at the top, and I’m also seeing this in 1.2.

What exact version are you using? Can you check against http://www.percona.com/downloads/XtraBackup/XtraBackup-1.3/d eb/lucid/x86_64/ if whether you are using the latest?

That’s where I got it from on Friday 16th, just before running into this problem.
The actual packages I used are:

Failed: xtrabackup_1.3-144.jaunty.11_amd64.deb
Failed: xtrabackup_1.3-144.lucid.1_amd64.deb
Worked: xtrabackup_1.2-132.jaunty.3_amd64.deb

I’ve ended up using the jaunty 1.2 package on lucid as there is no 1.2 package for lucid on your site.

I am having the exact same problem with this version:
http://www.percona.com/downloads/XtraBackup/XtraBackup-1.3/d eb/lenny/x86_64/xtrabackup_1.3-148.lenny.33_amd64.deb

Any ideas?