Install only qan packages

i already use prometheus and mysql exporter with percona app plugin for grafana.
I don’t want another prometheus shipped with PMM but I want to use qan too, so it is possible to install only QAN part of PMM ? how i can do this?

Thank you everyone

Hi Antonio Falzarano ,

About PMM Server:
It is possible, you have two ways: [LIST=1]
[]install everything manually. it is really not a trivial task.
you can find components on page.
repositories of all components are located on GitHub -
useful PMM Server setup information can be found in Ansible scripts
It is the totally unsupported way!
]you can start PMM Server as usual (as docker container) and use only QAN functionality (see below).
[/LIST]About PMM Client:
pmm-admin tool supports the possibility to add QAN and Metrics independently.
So it is possible to add only QAN monitoring without exporters.
just use
{code}sudo pmm-admin add mysql:queries{code}
instead of
{code}sudo pmm-admin add mysql{code}

anyway, keep in mind that percona exporters have SSL and Authentification support, this is not supported in original prometheus exporters (see
also, percona/mysqld_exporter smarter that original, we have three different targets for high, medium and low resolution metrics, because internal database performance debug requires high-resolution for some metrics.

Hi Mykola , thank you , i look into this informations.
About different resolution metrics there is some documentation that can i read, to understand differences with original mysql_exporter?

All Percona code is publically available, so if you want you can diff changes between percona/mysqld_exporter and prometheus/mysqld_exporter repositories.

Anyway, his part is not well documented yet, so I created a ticket - PMM-1162, it is publicly visible and you can register in our Jira and add self to the watcher list or vote for this ticket or write any suggestions :slight_smile:

Thank you Mykola, it seems that PMM-1162 is not a public ticket, i miss something?

Hi Antonio Falzarano , I’ve just configured the security settings for that issue, it should now load correctly.