Install Failing at Bootstrap - Access Denied

I’m trying to do an initial install of Xtradb on Ubuntu 14.04 three node cluster. Eveything installed via apt-get fine after updating the sources. I don’t have a DB loaded yet, just trying to get the initial config going.
I start the initial master server with: service mysql restart-bootstrap works fine
I go to the second node and do a: service mysql start and it fails.

On the master, I have this in the innobackup.backup.log
----------------------------------------------------------------------------------------------------------------------------------------------------- [INDENT]InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona LLC and/or its affiliates 2009-2013. All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

Get the latest version of Percona XtraBackup, documentation, and help resources:
http://www.percona.com/xb/p[/INDENT]
[INDENT]141113 15:42:29 innobackupex: Connecting to MySQL server with DSN ‘dbi:mysql:;mysql_read_default_file=/etc/mysql/my.cnf;mysql_read_default_group=xtrabackup;mysql_socket=/var/run/mysqld/mysqld.sock’ as ‘sstuser’ (using password: YES).
141113 15:42:29 innobackupex: Connected to MySQL server
141113 15:42:29 innobackupex: Starting the backup operation

IMPORTANT: Please check that the backup run completes successfully.
At the end of a successful backup run innobackupex
prints “completed OK!”.

innobackupex: Using server version 5.6.20-68.0-56

innobackupex: Created backup directory /tmp/tmp.34izv4eBe6
DBD::mysql::db selectrow_hashref failed: Access denied; you need (at least one of) the SUPER, REPLICATION CLIENT privilege(s) for this operation at /usr//bin/innobackupex line 3028.
innobackupex: got a fatal error with the following stacktrace: at /usr//bin/innobackupex line 3038.
main::mysql_query(‘HASH(0x198bba8)’, ‘SHOW SLAVE STATUS’) called at /usr//bin/innobackupex line 3057
main::get_mysql_slave_status(‘HASH(0x198bba8)’) called at /usr//bin/innobackupex line 4954
main::detect_mysql_capabilities_for_backup(‘HASH(0x198bba8)’) called at /usr//bin/innobackupex line 1907
main::backup() called at /usr//bin/innobackupex line 1592
innobackupex: Error:
Error executing ‘SHOW SLAVE STATUS’: DBD::mysql::db selectrow_hashref failed: Access denied; you need (at least one of) the SUPER, REPLICATION CLIENT privilege(s) for this operation at /usr//bin/innobackupex line 3028.
[/INDENT]

I then weep.

Config on master (in my.cnf) [INDENT]#

The MySQL database server configuration file.

You can copy this to one of:

- “/etc/mysql/my.cnf” to set global options,

- “~/.my.cnf” to set user-specific options.

One can use all long options that the program supports.

Run program with --help to get a list of available options and with

–print-defaults to see which it would actually understand and use.

For explanations see

http://dev.mysql.com/doc/mysql/en/server-system-variables.html

This will be passed to all mysql clients

It has been reported that passwords should be enclosed with ticks/quotes

escpecially if they contain “#” chars…

Remember to edit /etc/mysql/debian.cnf when changing the socket location.

[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

Here is entries for some specific programs

The following values assume you have at least 32M ram

This was formally known as [safe_mysqld]. Both versions are currently parsed.

[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]

* Basic Settings

user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking

wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://192.168.45.53,192.168.45.103,192.168.45.66
#wsrep_cluster_address=gcomm://
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
wsrep_sst_auth=“sstuser:password”
wsrep_node_address=192.168.45.53
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=govmint_db_cluster

Instead of skip-networking the default is now to listen only on

localhost which is more compatible and is not less secure.

bind-address = 127.0.0.1
bind-address = 0.0.0.0

* Fine Tuning

key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 192K
thread_cache_size = 8

This replaces the startup script and checks MyISAM tables if needed

the first time they are touched

myisam-recover = BACKUP
#max_connections = 100
#table_cache = 64
#thread_concurrency = 10

* Query Cache Configuration

query_cache_limit = 1M
query_cache_size = 16M

…[/INDENT]

ON the second node: [INDENT]#

The MySQL database server configuration file.

You can copy this to one of:

- “/etc/mysql/my.cnf” to set global options,

- “~/.my.cnf” to set user-specific options.

One can use all long options that the program supports.

Run program with --help to get a list of available options and with

–print-defaults to see which it would actually understand and use.

For explanations see

http://dev.mysql.com/doc/mysql/en/server-system-variables.html

This will be passed to all mysql clients

It has been reported that passwords should be enclosed with ticks/quotes

escpecially if they contain “#” chars…

Remember to edit /etc/mysql/debian.cnf when changing the socket location.

[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

Here is entries for some specific programs

The following values assume you have at least 32M ram

This was formally known as [safe_mysqld]. Both versions are currently parsed.

[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]

* Basic Settings

user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking

wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://192.168.45.53,192.168.45.103,192.168.45.66
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
wsrep_sst_auth=“sstuser:password”
wsrep_node_address=192.168.45.103
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=govmint_db_cluster

Instead of skip-networking the default is now to listen only on

localhost which is more compatible and is not less secure.

#bind-addre3ss = 0.0.0.0
#bind-address = 127.0.0.1

* Fine Tuning

key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 192K
thread_cache_size = 8

This replaces the startup script and checks MyISAM tables if needed

the first time they are touched

myisam-recover = BACKUP
#max_connections = 100
#table_cache = 64
#thread_concurrency = 10

* Query Cache Configuration

query_cache_limit = 1M
query_cache_size = 16M

…[/INDENT]


Any help appreciated!!!

Rodd

Does the ‘sstuser’ have required privileges???
You could try first with the ‘root’ to see that it works.

tkauppin,

You are so correct. I just assumed (yes, I made an ass out of me and me) and used sstuser as directed by a how-to. Ubuntu asks in the apt-get for the password for ‘root’ and that is worked!

Thanks for the response!