innobackupex produces compressed archives (can't apply logs)

I am using “innobackupex --export --tables-file=/root/tables.txt /tmp/backup”.

I’ve noticed that after the backup I can’t apply logs immediately (“innobackupex --apply-log /tmp/backup/2016-02-14_03-43-42”) and I need to decompress the files first (“innobackupex --decompress /tmp/backup/2016-02-14_03-43-42”).

Without applying the logs my files are corrupted.

  • twice as time is wasted on compression/decompression.

Is there a way to export through innobackupex without compression? I love innobackup because it can export files in parallel.

Can you please show us exact command used for backup and backup directory listing .

Ethaniel, are you following exactly what is being showed on the following manual’s page?
[URL=“https://www.percona.com/doc/percona-xtrabackup/2.3/xtrabackup_bin/restoring_individual_tables.html”]https://www.percona.com/doc/percona-...al_tables.html

T[/URL]alking about the compressed files, it’s due the use of --compress flag on executing backups as all the tablespaces including the shared one will be compressed with qpress and need to be decompressed before the apply-log phase. If you still have the compressed backup, try the follow to decompress files which extsion if .qp

for i in $(find -name "*.qp"); do qpress -vd $i $(dirname ${i}) && rm -f $i; done

After that you can go ahead and start the apply-log phase. Let us know please if it make sense and helped you, cheers.