innobackupex issue adding node to new cluster

I’m having an issue on a centos7 host creating a cluster. I have wsrep_sst_auth set properly in my.cnf however when the joiner is started the doner sees this:

mysql error log:

WSREP_SST: [INFO] Streaming the backup to joiner at 4444 (20150922 22:25:37.629)
WSREP_SST: [INFO] Evaluating innobackupex --defaults-file=/etc/my.cnf --defaults-group=mysqld --no-version-check $tmpopts $INNOEXTRA --galera-info --stream=$sfmt $itmpdir 2>${DATA}/innobackup.backup.log | socat -u stdio TCP:; RC=( ${PIPESTATUS[@]} ) (20150922 22:25:37.631)
WSREP_SST: [ERROR] innobackupex finished with error: 1. Check /var/lib/mysql//innobackup.backup.log (20150922 22:25:37.740)
WSREP_SST: [ERROR] Cleanup after exit with status:22 (20150922 22:25:37.741)


150922 22:25:37 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_file=/etc/my.cnf;mysql_read_default_group=xtrabackup;mysql_socket=/var/lib/mysql/mysql.sock' as 'sstuser' (using password: NO).
innobackupex: got a fatal error with the following stacktrace: at /usr//bin/innobackupex line 3011.
main::mysql_connect('abort_on_error', 1) called at /usr//bin/innobackupex line 1570
innobackupex: Error: Failed to connect to MySQL server: DBI connect(';mysql_read_default_file=/etc/my.cnf;mysql_read_default_group=xtrabackup;mysql_socket=/var/lib/mysql/mysql.sock','sstuser',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (13) at /usr//bin/innobackupex line 2995.

I’ve scoured the internet and all the advice I’ve found is to make sure the password is set correctly… my problem is when innobackupex on the joiner connects to the doner it isn’t using a password… which I can’t find a solution for.

Any ideas?

Can you connect MySQL manually with credentials set for sstuser in wsrep_sst_auth parameter ? Can you please try to set password for sstuser and retry.I’m not sure If sst works with passwordless user for wsrep_sst_auth parameter. Also, show us my.cnf file contents on donor and joiner.