GCP Deployment template completes with errors

I’ve been trying to use the Percona cluster deployment on the GCP marketplace and it keeps completing with errors.
This is the marketplace template I’ve been trying:

I’ve now tried 3 times, and the deployment always finishes with the same error.

On the step, it fails with the error:

percona has resource warnings
my-deplyment-perconaxtradb-software: {"ResourceType":"runtimeconfig.v1beta1.waiter","ResourceErrorCode":"412","ResourceErrorMessage":"Failure condition satisfied."}

There is no other information. I do see the following in stackdriver logging:

protoPayload: {
@type: "type.googleapis.com/google.cloud.audit.AuditLog" 
authenticationInfo: {
principalEmail: "my-email@someplace.com" 
methodName: "v2.deploymentmanager.deployments.insert" 
request: {
@type: "type.googleapis.com/deploymentmanager.deployments.insert" 
requestMetadata: {
callerIp: "2002:ac2:c88b:0:0:0:0:0" 
callerSuppliedUserAgent: "Pantheon Google-API-Java-Client Google-HTTP-Java-Client/1.26.0-SNAPSHOT (gzip)" 
resourceName: "projects/my-test-project/global/deployments/my-deployment" 
serviceName: "deploymentmanager.googleapis.com" 
status: {
code: 3 
message: "BAD_REQUEST" 

Has anyone ever had this issue? Does this error have any impact on the deployment? Right now we are only testing, but I would be afraid to use a deployment in production that has errors when it completes.

To be fair I am not quite a big fan of any Marketplace, dunno how to help with that GCP issue that you’re facing but why you’re not just installing it manually?!

IMO something’s wrong with that Template (don’t have the permissions to check though) but I would go for a manual installation first (self-scripted of course), if everything goes fine then simply create an Image for yourself and use it whenever required this way you’ll have everything under control.