Error starting query-history-all-5.1

Error starting query-history-all-5.1, check /var/lib/pt-agent/logs/start-stop.log and /var/lib/pt-agent/logs/

I’m getting this as my status on both of the servers that I have set up.

There is nothing in the .log file and the .run file just has a timestamp from it first tried to run, which was over an hour ago. I’ve confirmed that the user the agent/my.cnf file has permission to access mysql. The only command from /var/lib/pt-agent/services/start-query-history-all-5.1 that couldn’t be run was SET GLOBAL slow_query_log_use_global_control=‘all’
ERROR 1193 (HY000): Unknown system variable ‘slow_query_log_use_global_control’

I’m running Server version: 5.1.61-rel13.2-log (Percona Server (GPL), 13.2, Revision 431) on both servers.

Yes, we are already aware of a bug that brakes Query Analytics service for Percona Server 5.1. The bug is being worked on. I will try to update here once it’s fixed.

The bug that prevented the service from starting has been fixed. [url]Log in - Percona JIRA

I still don’t have any data on my graphs, though.

You probably need to restart the agent to re-initialize the Query Analytics service. This worked for me:

pt-agent --stop
pt-agent --daemonize

After a while, pt-agent --status shows “INFO query-history-all-5.1 is running” and also crontab -l shows two pt-agent entries.

I tried this several times, but it didn’t help . I’ve been trying a day + leaving it running, and alternatively trying to run it manually a few times. No go :frowning: