Disabling xb_doublewrite

Hello,

My Percona 5.7.16 server creates the xb_doublewrite file at startup despite the ‘innodb_doublewrite = 0’ setting (running on ZFS). However, the file doesn’t ever seem to be written to after the startup.

Is any way to disable creating this file at startup? I did try setting innodb_parallel_doublewrite_path to empty string, OFF, 0, etc, but it either ended with server refusing to start (empty), or the file being created (eg. ‘OFF’).

Thanks,
Kind regards,

It’s a bug that this file is being created with doublewrite disabled. Please follow this bug: https://bugs.launchpad.net/percona-server/+bug/1570682 (and click Affects Me)