PXC 5.7 Container keeps on restarting

Hi,

I’m getting the following error when I run the percona xtradb cluster: 5.7.32-31.47 version using the percona xtradb cluster operator: 1.10.0

{“log”:“2022-01-19T04:04:48.546980Z 0 [Note] InnoDB: Crash recovery did not find the parallel doublewrite buffer at /var/lib/mysql/xb_doublewrite\n”,“file”:"/var/lib/mysql/mysqld-error.log"}
{“log”:“2022-01-19T04:04:48.548324Z 0 [ERROR] [FATAL] InnoDB: Table flags are 0 in the data dictionary but the flags in file ./ibdata1 are 0x4800!\n”,“file”:"/var/lib/mysql/mysqld-error.log"}
{“log”:“2022-01-19 04:04:48 0x7f9964dd6240 InnoDB: Assertion failure in thread 140296798954048 in file ut0ut.cc line 924\nInnoDB: We intentionally generate a memory trap.\nInnoDB: Submit a detailed bug report to http://bugs.mysql.com.\nInnoDB: If you get repeated assertion failures or crashes, even\nInnoDB: immediately after the mysqld startup, there may be\nInnoDB: corruption in the InnoDB tablespace. Please refer to\nInnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html\nInnoDB: about forcing recovery.\n”,“file”:"/var/lib/mysql/mysqld-error.log"}
{“log”:“04:04:48 UTC - mysqld got signal 6 ;\n”,“file”:"/var/lib/mysql/mysqld-error.log"}
{“log”:“This could be because you hit a bug. It is also possible that this binary\nor one of the libraries it was linked against is corrupt, improperly built,\nor misconfigured. This error can also be caused by malfunctioning hardware.\nAttempting to collect some information that could help diagnose the problem.\nAs this is a crash and something is definitely wrong, the information\ncollection process might fail.\nPlease help us make Percona XtraDB Cluster better by reporting any\nbugs at https://jira.percona.com/projects/PXC/issues\n",“file”:"/var/lib/mysql/mysqld-error.log”}

Images Used:
Mysql Percona XtraDB Cluster: percona/percona-xtradb-cluster:5.7.32-31.47
Mysql Percona XtraDB Cluster Operator: percona/percona-xtradb-cluster-operator:1.10.0

My requirement is I need to run MySql Percona XtraDB Cluster with version “5.7.x” since my APP is validated only against the 5.7. Also I’m getting the same error when I run with the latest version of percona/percona-xtradb-cluster: :5.7.35-31.53

I’m not sure whether this issue is happening because I’m using the latest version of PXC Operator “1.10.0” with old version of PXC “5.7.x”. Is there is any compatibility matrix which explains about for which version of PXC we need to use which PXC Operator.

Any help will be really appreciable.

Thanks In Advance,
Arun V

1 Like

The error may indicate that something wrong with the storage.
Can you provide your yaml file and also
kubectl get pv and kubectl get pvc
output?

1 Like