Directory error -while executing pt-deadlock-logger


I have installed percona-2.2.7

Im getting the same error while using any command such as ‘pt-table’,pt-% in any directory

[root@MYSQLTEST ~]# pt-deadlock-logger --create-dest-table --dest D=audit,t=deadlocks –u root –pxxxxxxx
: No such file or directory

[root@MYSQLTEST perconatoolkit-2.2.7]# pt-deadlock-logger localhost -u root -pxxxx --create-dest-table --dest D=auditr,t=deadlocks
: No such file or directory

[root@MYSQLTEST man1]# pt-deadlock-logger localhost -u root -pxxx --create-dest-table --dest D=audit,t=deadlocks
: No such file or directory

PLease help me

while testing

got below error

[root@MYSQLTEST ~]# time SLOW_TESTS=1 PT_PERL_LIB=/pt/lib prove -rs /pt/t/
Cannot determine source for /pt/t/ at /usr/share/perl5/App/ line 496

real 0m0.109s
user 0m0.011s
sys 0m0.003s

From the perconatoolkit-2.2.7 directory, change into the bin directory, and try:

./pt-deadlock-logger --create-dest-table --dest D=audit,t=deadlocks –u root –pxxxxxxx

That will tell the OS to look at the specific file in the directory you are in instead of looking for it in your PATH.

Thanks for your answer…

but still getting same error…

[root@MYSQLTEST bin]# ls
mysqljsonimport pt-heartbeat pt-slave-find
pt-agent pt-index-usage pt-slave-restart
pt-align pt-ioprofile pt-stalk
pt-archiver pt-kill pt-summary
pt-config-diff pt-mext pt-table-checksum
pt-deadlock-logger pt-mysql-summary pt-table-sync
pt-diskstats pt-online-schema-change pt-table-usage
pt-duplicate-key-checker pt-pmp pt-upgrade
pt-fifo-split pt-query-digest pt-variable-advisor
pt-find pt-show-grants pt-visual-explain
pt-fingerprint pt-sift
pt-fk-error-logger pt-slave-delay
[root@MYSQLTEST bin]# ./pt-deadlock-logger --create-dest-table --dest D=audit,t=deadlocks –u root –pxxxx
: No such file or directory

the reason may the installation of percona, not properly installed???

Check to see if the file is set to executable, or just set it regardless:

chmod +x ./pt-deadlock-logger

Then try to run just the script with no parameters to see if it picks it up or not: