Data structure corruption

Hello, I have a Data structure corruption in a table from my database.
The first thing i did is to get the files from my old database server, but it looks like there is a problem with them.
I only have mytable.frm and mytable.idb files, no indexes or metadata, but after running
mysqlfrm --server=root:rootpassword@localhost mysql:,mytable.frm --port=3307
I got the structure, I have not the original datafile (ibdata1) so I dont know if i will be able to recover the data, i tried with
ibdconnect -o mysql/data/ibdata1 -f mysql/data/mydb/mytable.ibd -t mytable -d mydb and the results:
SYS_INDEXES is updated successfully
but after going to mysql and running
alter table mytable discard tablespace;
(here then did the shutoff mysqld, copy the old mytable.ibd file and did the ibdconnect thing and go on)
and then:
alter table mytable import tablespace;
the same error occurs:
mysql> alter table wp_wp_pro_quiz_question import tablespace;
“ERROR 1815 (HY000): Internal error: Cannot reset LSNs in table ‘“mydb”.“mytable”’ : Data structure corruption”
so, what am i doing wrong?