character set warning

I got lots of warnings in the error file:

[Warning] Client failed to provide its character set. ‘latin1’ will be used as client character set

How can I fixed it? the only connection is the slave replication.

Thanks

Hi,

Which MySQL/Percona version you are using ? I’m not sure but you might be hitting this bug http://bugs.mysql.com/bug.php?id=69160
Can you provide some more details like which connector you are using with version? also my.cnf of master and slave? Thanks.

Hi Folks, I have the same issue. The error log file start to be huge.

I tried to disable the warnings from my.cnf using log-warnings=0 and log_warnings_suppress=1592 but without any result, warnings are still there.

This error is generated because of Haproxy when he’s doing mysql-check. Any idea how to solve this issue or disable warnings?

bug already reported by someone else: http://bugs.mysql.com/bug.php?id=72543

Installed packages:
ii percona-toolkit 2.2.7 Advanced MySQL and system command-line tools
ii percona-xtrabackup 2.1.9-744-1.precise Open source backup tool for InnoDB and XtraDB
ii percona-xtradb-cluster-client-5.6 5.6.15-25.5-759.precise Percona Server database client binaries
ii percona-xtradb-cluster-common-5.6 5.6.15-25.5-770.precise Percona Server database common files (e.g. /etc/mysql/my.cnf)
ii percona-xtradb-cluster-galera-3.x 216.precise Galera components of Percona XtraDB Cluster
ii percona-xtradb-cluster-server-5.6 5.6.15-25.5-759.precise Percona Server database server binaries

Thanks in advance

Any idea :wink: up …

Hi Folks, after one month I’m still looking for a solution related to this issue. Anyone from Percona team have an idea about this bug?

Hi TomD,

Thanks for looking this case.

Just FYI:

Distro: Ubuntu Precise (12.04.4)

Error log:

  • Size: -rw-r----- 1 mysql root 1.1G Jun 12 16:45 staging.err
  • Message: 2014-06-12 16:45:41 1243 [Warning] Client failed to provide its character set. ‘latin1’ will be used as client character set.

Installed Packages related to Percona:
percona-toolkit ---- 2.2.8
percona-xtrabackup ---- 2.1.9-744-1.precise
percona-xtradb-cluster-client-5.6 ---- 5.6.15-25.5-759.precise
percona-xtradb-cluster-common-5.6 ---- 5.6.15-25.5-770.precise
percona-xtradb-cluster-galera-3.x ---- 216.precise
percona-xtradb-cluster-server-5.6 ---- 5.6.15-25.5-759.precise

haproxy ---- 1.5~dev26-2ppa1~precise

Thanks in advance

Hi TomD,

Have you been able to reproduce the bug?

Best regards,

Hi TomD,

Thanks for this info. Looking forward to have some news about this bug

I am sorry to say that we are not prioritising a fix for this bug at the moment and are leaving this for Oracle to address for the time being at http://bugs.mysql.com/bug.php?id=72543.

One thing that could be done now is to file this bug (with a reference to #72543) on https://bugs.launchpad.net/percona-server/. Someone might comment with a workaround there, and we also may get an idea of how many users are affected, which influences prioritisation.

Hi Iaurynas,

No problem. As it’s upstream bug, you should just notify them to look at this.