Cannot start PMM Server v2.40.0 due to error


Cannot start PMM Server v2.40.0 due to error.

Steps to Reproduce:

Just start the PMM Server docker container.




logger=settings t=2023-10-06T10:39:08.545433262+09:00 level=info msg="Starting Grafana" version= commit= branch= compiled=1970-01-01T09:00:00+09:00
logger=settings t=2023-10-06T10:39:08.545574732+09:00 level=info msg="Config loaded from" file=/usr/share/grafana/conf/defaults.ini
logger=settings t=2023-10-06T10:39:08.545583451+09:00 level=info msg="Config loaded from" file=/etc/grafana/grafana.ini
logger=settings t=2023-10-06T10:39:08.54558833+09:00 level=info msg="Path Home" path=/usr/share/grafana
logger=settings t=2023-10-06T10:39:08.545592806+09:00 level=info msg="Path Data" path=/srv/grafana
logger=settings t=2023-10-06T10:39:08.545597087+09:00 level=info msg="Path Logs" path=/srv/logs
logger=settings t=2023-10-06T10:39:08.545601277+09:00 level=info msg="Path Plugins" path=/srv/grafana/plugins
logger=settings t=2023-10-06T10:39:08.545606864+09:00 level=info msg="Path Provisioning" path=/usr/share/grafana/conf/provisioning
logger=settings t=2023-10-06T10:39:08.545611739+09:00 level=info msg="App mode production"
logger=sqlstore t=2023-10-06T10:39:08.545671777+09:00 level=info msg="Connecting to DB" dbtype=postgres
logger=migrator t=2023-10-06T10:39:08.546534706+09:00 level=error msg="alert migration failure: could not get migration log" error="failed to check table existence: dial tcp [::1]:5432: connect: connection refused"

Expected Result:

It should get started successfully.

Actual Result:

Please see above logs. It was failed to start during alert migration.

Additional Information:

I’m running the PMM Server in Kubernetes.

Hi @chadr !
Can you please show how do you start PMM in Kubernetes, do you use helm chart or something else and which options do you use.


It was occurred when I tired to change the password of Grafana before running /opt/
In fact, I have rebuilt the pmm-server container with my custom entrypoint like below.


set -ex

if [ "$ADMIN_PASSWORD" != "" ]; then
	change-admin-password "$ADMIN_PASSWORD"

exec /opt/

When I commented out the chnage-admin-password not to run it, the pmm-server ran successfully but if I ran it before the exec /opt/, the issue has occurred.

Before the PMM Sever v2.40.0, above custom entrypoint worked. :frowning:

Hi @chadr !
It seems this is a known issue and the ticket is open here: [PMM-12576] Change password for Admin is NOT working from the terminal for upgraded instances - Percona JIRA
So I would suggest to watch it for updates.