Cannot show data on MongoDB replset dashboard after deploy monitor cassandra cluster

Dear supporters,

I updated latest version 1.17.4, it worked perfectly until I installed and monitored cassandra node. I installed PMM-client and deploy cassandra follow this link: I deployed successfully and show information on cassandra dashboard. But a few days ago, I had issue with mongoDB replicate, I tried to access MongoDB replset dashboard, It did not show any replicate data of MongoDB, only show cassandra cluster name “Adp_cluster”, this is a screenshot

I tried to check pmm client status, i found all my database nodes (mysql and mongoDB) install external-service cassandra like this:


mongodb:queries my-mongodb - YES query_examples=true

linux:metrics my-mongodb 42000 YES -

mongodb:metrics my-mongodb 42003 YES

Job name Scrape interval Scrape timeout Metrics path Scheme Target Labels Health

cassandra 1m0s 10s /metrics http instance=“hadoop-xxx” UP

Would you please help me fix this issue ?

Thank you!


It looks like your MongoDB services were added without a cluster name.

We have fixed it for PMM2

But dashboard variables are changed in PMM2 so you can’t just take a dashboard from PMM2 and import it into PMM1.

I will prepare a staging with PMM1 and provide you with required changes.

1 Like

Variable “$cluster” should be changed by set “.*” for parameter “Custom all value”.

1 Like

Dear Adivinho,

Thank you for your support. It worked perfectly !

Best Regards,

1 Like