Cannot increase gcache.size value for XtraDB cluster

I have 2 XtraDB cluster instances on the same machine. 4300 instance is having the default ports while 4301 is having custom ports. For 4300 i can change the size of the gcache.size file by changing this line in wsrep_provider_options=“gcache.size = 5G” in the config file. For 4301 instance no matter what value I set in the config file for gcach.size I always thet the default value of 128 MB. Any reason why 4301 instance starts galera.cache file with 128 MB no matter of the wsrep_provider_options=“gcache.size = 5G” setting?
Also what happens if the size of the writesets to be stored in galera.cache exceeds the size of the file. Is xtraDB cluster going to create new files with teh same size? Is there a limit in the number of files or size of the files to be created?
Thank you,

Can you paste the configuration file(s) you use to start the second instance?

Also, the gcache works in circular fashion, oldest writesets are replaced with recent ones. The greater the gcache size is, the better chance a node that is temporarily of of cluster will be able to join using IST instead of SST.

Have you resolved gcache.size problem? If so, what was that?
Yesterday I upgraded to PXC 5.6.26 (from PXC 5.6.21)
And instead of gcache.size=6G as in my.cfg
it creates default size galera.cache (128M)

I’m wondering if you could share what you did to resolve the issue