Can start mysql or resync SST after last update

Hi Guys,

We just updated our mysql cluster from 5.6.26-25.12-1.precise to 5.6.27-25.13-1.precise

Package involved:

percona-xtradb-cluster-client-5.6 (5.6.26-25.12-1.precise => 5.6.27-25.13-1.precise)
percona-xtradb-cluster-common-5.6 (5.6.26-25.12-1.precise => 5.6.27-25.13-1.precise)
percona-xtradb-cluster-galera-3.x (3.12.2-1.precise => 3.13-1.precise)
percona-xtradb-cluster-server-5.6 (5.6.26-25.12-1.precise => 5.6.27-25.13-1.precise)

Since the update, we have been able to start MySQL on 2 nodes but the third one don’t want to start or sync

Tried to start mysql and forcing the donor to be the server1 but still the same issue

On the failed server:
-rw-rw---- 1 mysql mysql 104 Jan 11 15:29 grastate.dat
-rw-rw---- 1 mysql mysql 0 Jan 11 14:20 gvwstate.dat

cat grastate.dat

GALERA saved state

version: 2.1
uuid: 00000000-0000-0000-0000-000000000000
seqno: -1

Any idea how to force the server to rsync and start?

Tried again to restart the server specifying the donor to be server3

Logs from the server2 (broken):

Logs from server3 (donor):

Any help or idea will be welcome. :wink:

I tried to force SST sync but it fail each time (open file limit ?)

Seems to be hard to recover this server :s

And It seems that we have this error with all DB on the affected node

The affected node got kicked and die when triying to restart it:

Thanks in advance

Hi Guys,

I have the feeling that there’s not anymore someone who can answer our questions and it’s the case for different topic here not only mine…