xtrabackup --prepare --compact fails


I have a problem with innobackupex --compact --apply-log (xtrabackup(_56) --prepare / percona-xtrabackup-2.1.9-744.rhel6.x86_64) failing with:

2014-05-08 09:25:45 7fc9a506e700 InnoDB: uncompressed page, stored checksum in field1 3735928559, calculated checksums for field1: crc32 177807968, innodb 3475755373, none 3735928559, stored checksum in field2 3735928559, calculated checksums for field2: crc32 177807968, innodb 1624572976, none 3735928559, page LSN 0 0, low 4 bytes of LSN at page end 0, page number (if stored to page already) 0, space id (if created with >= MySQL-4.1.1 and stored already) 0
InnoDB: Page may be a freshly allocated page
2014-05-08 09:25:45 7fc9a506e700 InnoDB: Assertion failure in thread 140504033847040 in file rem0rec.cc line 577
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
innobackupex: Error:
innobackupex: ibbackup failed at /usr/bin/innobackupex line 2560.

(percona-xtrabackup-2.1.8-733.rhel6.x86_64 fails with:
InnoDB: Assertion failure in thread … in file rem0rec.cc line 575).

This is on PXC 5.6 (innobackupex fails on every node), same problem even if i use single node with wsrep_provider=none.
If I restore databases from mysqldump then innobackupex works IF I don’t do any updates on databases. Even removing one row from db:
[mdl26]> delete from mdl_log where id=6943;
Query OK, 1 row affected (0.01 sec)) and innobackupex fails.

(innochecksum doesn’t report any errors in original .ibd files in /var/lib/mysql/, but reports errors in files copied with innobackupex:
for example: file mdl_log.ibd = 9437184 bytes (576 pages)…
InnoChecksum; checking pages in range 0 to 575
Fail; page 13 invalid (fails old style checksum)).

My innobackupex options:
innobackupex --galera-info --no-timestamp --parallel=4 --defaults-file=/etc/my.cnf --user=root --compact /home/bu/xtrabackup/last
innobackupex --galera-info --no-timestamp --parallel=4 --defaults-file=/etc/my.cnf --user=root --compact --apply-log /home/bu/xtrabackup/last

Innobackupex works w/out --compact option.