xbcrypt: unable to set libgcrypt thread cbs

When I try to enable encryption with percona-xtrabackup-24, I’m getting the following error message:

xbcrypt: unable to set libgcrypt thread cbs - User defined source 1 : Not supported

I’ve further narrowed the problem down to xbcrypt. I’m getting the same error message with the following command:

xbcrypt -v --encrypt-key='12345678901234567890123456789012' --encrypt-algo=AES256 -i "test.txt" -o "test.txt.xbcrypt"

I’m running CentOS 7 with the following packages:

Installed Packages
libgcrypt.x86_64 1.5.3-13.el7_3.1 @centos7-updates-x86_64
libgcrypt-devel.x86_64 1.5.3-13.el7_3.1 @centos7-updates-x86_64
mysql-community-server.x86_64 5.7.19-1.el7 @mysql57-community-centos7
percona-xtrabackup-24.x86_64 2.4.8-1.el7 @centos7-percona

I’ve tried disabling SELinux and turning off FIPS mode. I have this same example working on CentOS 6 with MySQL Community 5.6 and xtrabackup 2.3. The only references to this error that I’ve found are in the source code.

Does anyone have any suggestions on how to resolve this error? Is it a bug?