WSREP_SST: [ERROR]

Hi!

When I start my DB, this errors are generated.
How can I fix?

[ERROR] Cleanup after exit with status:32 (20130723 14:21:44.199) WSREP_SST: [ERROR] Killing nc pid 28030 (20130723 14:21:44.237) tar: Este não parece ser um arquivo-tar tar: Exiting with failure status due to previous errors WSREP_SST: [ERROR] Error while getting data from donor node: exit codes: 137 2 (20130723 14:21:44.241) WSREP_SST: [INFO] Removing the sst_in_progress file (20130723 14:21:44.242) WSREP_SST: [ERROR] Cleanup after exit with status:32 (20130723 14:21:44.243) 130723 14:21:44 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role ‘joiner’ --address ‘MYSQL03’ --auth ‘USUARIO:SENHA’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --parent ‘28776’: 32 (Broken pipe) 130723 14:21:44 [ERROR] WSREP: Failed to read uuid:seqno from joiner script. 130723 14:21:44 [ERROR] WSREP: SST failed: 32 (Broken pipe) 130723 14:21:44 [ERROR] Aborting

Hi;

Could you copy and paste your my.cnf file configuration?

When I have this problem , I juste add this line in my conf “wsrep_sst_donor= node 1”.

A.

Allan,
Check if xtrabackup is already running on any of the nodes. It could be left orphaned after last failed SST. Also make sure all the important TCP ports are opened between nodes - 4567, 4444, 4568.

Hi!
I met the same question yet ,and i modify my.cnf ,you could try to use “rsync” sst_method replace “xtrabackup” and try again. of course you have to make sure your Selinux stat is disabled ,and iptables is shut down! Good Luck!

Rsync method is a blocking one, so much less suitable for production use.
There is no need to “shutdown” iptables - configuring it properly is enough. Also with some effort Selinux can be adjusted. This document can be helpful too:
http://www.mysqlperformanceblog.com/2012/12/20/percona-xtradb-cluster-selinux-is-not-always-the-culprit/