Why is Percona setting each time I make sudo apt-get

I have installed Percona 5.5 in ubuntu 12.10. And work witthout problems but when aI tried to make a:

sudo apt-get install

I obtain error like these:

Setting up percona-server-server-5.5 (5.5.30-rel30.1-465.quantal) ...


 * Stopping MySQL (Percona Server) mysqld [ OK ] 


chown: cannot access `/var/run/mysqld': No such file or directory

always try to install again the percona server, it is like is detected that is not correctly installed. Is there any solution for this problem?

Hi,

Yes, seems it is not correctly installed. Try to create the /var/run/mysqld

mkdir -p /var/run/mysqld

then apt-get -f install or dpkg-reconfigure percona-server-server

Hi Miguel Angel

Thank for your answer but I tried other thing. I removed all the percona package and a make a dpkg-reconfigure and apt-get install f to leave the system with the package in a correct state.

After that I tried to install again percona server and client and I get an error again in the post script installation. Looking in the mysql logs I get this:

130418 17:21:59 Percona XtraDB ([URL=“http://www.percona.com”]http://www.percona.com[/URL=“http://www.percona.com”]) 5.5.30-rel30.2 started; log sequence number 1597945

ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE user ADD column Show_view_priv enum(‘N’,‘Y’) CHARACTER SET utf8 NOT ’ at line 1

The thing is that percona is correctly installed and working but the package it is marked with half configured status, so each time i tried to make an apt-get 'something’try to install percona again.

This is similar to https://bugs.launchpad.net/ourdelta/+bug/484120 Several solutions are proposed there.