Unable to create a slave from backup

Hello,
I am starting to play with master-slave replication but I have a problem creating my first slave.
I followed this guide http://www.percona.com/doc/percona-xtrabackup/2.2/howtos/setting_up_replication.html and as soon as I start the slave I get this error

41017 10:28:16 [Note] 'CHANGE MASTER TO executed'. Previous state master_host='', master_port='3306', master_log_file='', master_log_pos='4'. New state master_host='master', master_port='3306', master_log_file='mysql-bin.000005', master_log_pos='241487'.
141017 10:28:19 [Note] Slave SQL thread initialized, starting replication in log 'mysql-bin.000005' at position 241487, relay log './mysqld-relay-bin.000001' position: 4
141017 10:28:19 [Note] Slave I/O thread: connected to master 'repslave@master:3306',replication started in log 'mysql-bin.000005' at position 241487
141017 10:28:19 [ERROR] Slave SQL: Could not execute Write_rows event on table dbispconfig.sys_log; Duplicate entry '7621412' for key 'PRIMARY', Error_code: 1062; handler error HA_ERR_FOUND_DUPP_KEY; the event's master log mysql-bin.000005, end_log_pos 241804, Error_code: 1062
141017 10:28:19 [Warning] Slave: Duplicate entry '7621412' for key 'PRIMARY' Error_code: 1062
141017 10:28:19 [ERROR] Error running query, slave SQL thread aborted. Fix the problem, and restart the slave SQL thread with "SLAVE START". We stopped at log 'mysql-bin.000005' position 241563

The command to setup the replication is

CHANGE MASTER TO MASTER_HOST='master', MASTER_USER='repslave', MASTER_PASSWORD='password',MASTER_LOG_FILE='mysql-bin.000005',MASTER_LOG_POS=241487;

the content of xtrabackup_binlog_info is
mysql-bin.000005 241487

The mysql server is 5.5.40 on both servers and the my.cnf is the same (excluding server-id) on both servers.
I’m using xtrabackup 2.2.5

I tried the operation 3 times but I got the same result every time.

What I am doing wrong?

Hi,

Can you please provide exact commands for taking and preparing backup?
Also are you using “STOP SLAVE” and “RESET SLAVE” before trying to setup replication next time?

I have been able to do the replica changing

mysql_query(%mysql, “FLUSH ENGINE LOGS”); with mysql_query(%mysql, “FLUSH NO_WRITE_TO_BINLOG ENGINE LOGS”);

in innobackupex (thanks to giantmangu88)