Unable to add MongoDB Replicaset to PMM

Hi Team,

We are on Percona server for MongoDB 4.4 version.
PMM Client version - pmm2
PMM server is Installed using Docker Image.

When we are trying to configure PMM for our MongoDB replica sets.
Even though, when we add –replication-set tag, It is not being detected in the MongoDB Replica Set summary dashboard.

I have used the below command to add the nodes to PMM.
(Ran this command on all the 3 nodes present in the replica set).

pmm-admin add mongodb --username=pmm --password=password --environment=DEV --replication-set=replication_name --authentication-mechanism=SCRAM-SHA-1

Can you please review and help me out.

Thank you
Kiran

1 Like

Hello, you don’t need to provide the --replication-set flag as PMM will automatically detect the members of a replica set based on rs.status() output. Try adding as follows:

pmm-admin add mongodb --username=pmm --password=password --environment=DEV

Also make sure you select the Last 5 min in the dashboard, and give it 1-2 min time to populate to check for the new member.

2 Likes

Hello Ivan,

Thank you for your response.
I tried adding the service without --replication-set flag but, unable to see the replicaset on the dashboard.

Below is the screenshot of pmm-admin list post service addition.

Do we need to enable any setting/change configuration for the replicaset to be displayed on the dashboard?
Please help me out.

Thank you,
Kiran

2 Likes

Hi @igroene

We were able to figure out the Issue here.
pmm-server version we are on is 2.20.0
pmm2-client version is 2.29.1

We tried upgrading the docker image of the pmm-server to 2.28.0 and It resolved the Issue. (Are there any version specifications[server and the client] that you recommend while configuring the PMM?

Thank you for your time and help on this.

Regards,
Kiran

1 Like

Hello, glad to hear you sorted it out. As per the manual always use a PMM server version higher or equal to the client. Ideally they should be the same version except during an upgrade.

1 Like