trying to install on Ubuntu - mysqld.log fPermission denied

Hello, I’m trying to install “percona-xtradb-cluster-server-5.7” on Ubuntu, but keep running into the same error. I can install no problem on a fresh install og Ubuntu with no MySQL, however if MySQL already exists, I can’t seem to get past this error to install Percona.

[ERROR] Could not open file ‘/var/log/mysqld.log’ for error logging: Permission denied

which results in this:

2018-02-26T19:30:56.324727Z 0 [ERROR] Aborting

dpkg: error processing package percona-xtradb-cluster-server-5.7 (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of percona-xtradb-cluster-57:
percona-xtradb-cluster-57 depends on percona-xtradb-cluster-server-5.7 (>= 5.7.20-29.24-1.xenial); however:
Package percona-xtradb-cluster-server-5.7 is not configured yet.

dpkg: error processing package percona-xtradb-cluster-57 (–configure):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu7) …
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for systemd (229-4ubuntu16) …

How can I install Percona cluster on a system that once that MySQL installed?


What version of MySQL you had previously installed (was it community version or the one from the distribution repo)? Can you please share the output of:

dpkg -l | grep mysql 



It was the newest version that came with Ubuntu 16.4, It’s no longer installed so I’m unable to get a result from the grep comment. I’ve tried removing the file, reset the permissions and still no luck. Any advice would be great. thanks!