tokudb restore

I am having no luck restoring from a tokudb backup. I am using tokudb version 5.7.23-24 on mysql 5.7.23-24 (centos 7.6). I’ve followed the docs on how to backup tokudb.

set tokudb_backup_dir=’/data/backups’;

This backs up successfully. I rsync the files that the backup created in /data/backups/mysql_data_dir to the remote system under the my.cnf datadir directory and I also rsync’d the backup files in /data/backups/mysql_log_bin to the log_bin directory on the remote system.

When I go to start mysql on the remote system it is just a continuous loop of restarting. The db never recovers and I see this in the log file

Checksum failure while reading header in file ./dbname/path_to_some_file.tokudb.

I’ve tried multiple times to backup and restore and it never works.

There doesn’t seem to be much documentation on restoring tokudb. I imagine it should work like backing up and restoring an xtrabackup backup.

My ultimate goal is to setup a master slave environment.

Any pointers on the correct way to restore a tokudb backup would be most helpful.

1 Like

I am also running into this https://jira.percona.com/browse/PS-5193

I assume a database restart is needed to stop the excessive logging.

This tokudb is painful!

1 Like

Hi, any luck sorting this out? Running into the same issue and wondering what we are supposed to do to get the server to start. Delete the files…? I should be able to restore the data from backups provided i can get the server started again…

1 Like

So going back thru my notes, I think I noticed that /var was filling up with log messages from enabling tokudb backup.

A restart did not work as the logs were still going crazy. I tried this command but it didn’t work

sudo ps_tokudb_admin --disable-backup -u root -p

What I had to do to solve my issue was to remove this from /etc/my.cnf

[mysqld_safe]
preload-hotbackup

and then restart mysql. Hopefully this helps

1 Like

Actually not sure if what I just mentioned will help you. What I have in my notes is more to the logging issue and not the restore issue.

I do see that I was never able to restore and configure mysql in a master/slave with tokudb :frowning:

1 Like

Hi, thanks for the response. I suspect i have an actual issue with corrupted data and that won’t help me start the server.
I am getting errors like this:

Checksum failure while reading header in file: {filename}.tokudb

According to this presentation, checksum issues are not recoverable… so i guess its start again, and slowly restore data from backups.
I’m beginning to think TokuDB is just not worth the engineering hassle for my applications…

Cheers

1 Like