somebody help me.

hello. help me plz…


OS : solaris 10(x86 32bit)
RAM : 1gb

#> ./ndbd
2010-01-04 01:51:18 [ndbd] INFO – Configuration fetched from ‘localhost:1186’, generation: 1
2010-01-04 01:51:18 [ndbd] INFO – Angel pid: 9160 ndb pid: 9161
NDBMT: non-mt
2010-01-04 01:51:18 [ndbd] INFO – NDB Cluster – DB node 3
2010-01-04 01:51:18 [ndbd] INFO – mysql-5.1.39 ndb-7.0.9b –
2010-01-04 01:51:18 [ndbd] INFO – WatchDog timer is set to 6000 ms
2010-01-04 01:51:18 [ndbd] INFO – Ndbd_mem_manager::init(1) min: 44Mb initial: 244Mb
Adding 244Mb to ZONE_LO (1,7807)
2010-01-04 01:51:18 [ndbd] INFO – Start initiated (mysql-5.1.39 ndb-7.0.9)
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
NDBFS/AsyncFile: Allocating 310256 for In/Deflate buffer
WOPool::init(61, 9)
RWPool::init(22, 13)
2010-01-04 01:51:22 [ndbd] INFO – DBLQH could not allocate memory for LogPageRecord
2010-01-04 01:51:22 [ndbd] INFO – Requested: 32768x5760 = 188744191 bytes
2010-01-04 01:51:22 [ndbd] INFO – Error handler startup shutting down system
2010-01-04 01:51:22 [ndbd] INFO – Error handler shutdown completed - exiting
2010-01-04 01:51:22 [ndbd] INFO – Angel received ndbd startup failure count 1.
2010-01-04 01:51:22 [ndbd] ALERT – Node 3: Forced node shutdown completed. Occured during startphase 0. Caused by error 2327: ‘Memory allocation failure, please decrease some configuration parameters(Configuration error). Permanent error, external action needed’.

config.ini

[NDBD DEFAULT]
NoOfReplicas: 1
DataDir: /usr/local/web_apps/mysql/clusterdata

DataMemory: 60M
IndexMemory: 10M
BackupMemory: 7M

[MGM DEFAULT]
PortNumber: 1186
DataDir: /usr/local/web_apps/mysql/clusterdata

[TCP DEFAULT]
#SendBufferMemory: 10M
SendBufferMemory: 2M
PortNumber: 2202

[NDB_MGMD]
Id: 1
HostName: 127.0.0.1
ArbitrationRank: 1

[NDBD]
Id: 3
HostName: localhost

[MYSQLD]
Id: 5
HostName: 127.0.0.1

my.cnf

[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

Here follows entries for some specific programs

The MySQL server

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
#key_buffer_size = 48M
key_buffer_size = 10M
max_allowed_packet = 1M
table_open_cache = 4
sort_buffer_size = 64K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 128K

default-character-set=euckr
skip-character-set-client-handshake
character-set-filesystem=euckr
default-collation = euckr_korean_ci

ndbcluster # run NDB engine
ndb-connectstring=localhost # location of MGM node

Don’t listen on a TCP/IP port at all. This can be a security enhancement,

if all processes that need to connect to mysqld run on the same host.

All interaction with mysqld must be made via Unix sockets or named pipes.

Note that using this option without enabling named pipes on Windows

(using the “enable-named-pipe” option) will render mysqld useless!

#skip-networking
server-id = 1

Uncomment the following if you want to log updates

log-bin=mysql-bin

binary logging format - mixed recommended

#binlog_format=mixed

Uncomment the following if you are using InnoDB tables

#innodb_data_home_dir = /usr/local/mysql/data/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/data/

You can set …_buffer_pool_size up to 50 - 80 %

of RAM but beware of setting memory usage too high

#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M

Set …_log_file_size to 25 % of buffer pool size

#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

Remove the next comment character if you are not familiar with SQL

#safe-updates

[myisamchk]
key_buffer_size = 8M
sort_buffer_size = 8M

[mysqlhotcopy]
interactive-timeout

top result

last pid: 9185; load avg: 0.01, 0.02, 0.03; up 3+12:15:18 01:59:27
72 processes: 71 sleeping, 1 on cpu
CPU states: 99.5% idle, 0.0% user, 0.5% kernel, 0.0% iowait, 0.0% swap
Memory: 1024M phys mem, 726M free mem, 1028M total swap, 990M free swap

PID USERNAME LWP PRI NICE SIZE RES STATE TIME CPU COMMAND
9185 root 1 59 0 2484K 1412K cpu/0 0:00 0.20% top
9114 root 10 59 0 14M 3252K sleep 0:02 0.14% ndb_mgmd
805 root 46 59 0 611M 93M sleep 4:41 0.02% java
700 zentop 1 59 0 8416K 1616K sleep 0:02 0.01% sshd
7 root 12 59 0 11M 4556K sleep 0:07 0.00% svc.startd
752 root 1 59 0 269M 4708K sleep 0:13 0.00% httpd
770 root 1 59 0 7456K 3244K sleep 0:14 0.00% httpd
405 root 1 59 0 1112K 644K sleep 0:00 0.00% utmpd
9 root 15 59 0 10M 6340K sleep 0:23 0.00% svc.configd
159 root 29 59 0 6512K 2444K sleep 0:10 0.00% nscd
1 root 1 59 0 2160K 776K sleep 0:07 0.00% init
349 daemon 4 59 0 13M 7084K sleep 0:05 0.00% nfsmapid
581 root 16 59 0 13M 3256K sleep 0:05 0.00% fmd
385 root 4 59 0 4616K 1904K sleep 0:05 0.00% inetd
521 daemon 2 60 -20 2336K 1304K sleep 0:04 0.00% nfsd

I have two suggestions:

  1. read http://catb.org/~esr/faqs/smart-questions.html
  2. you are playing with fire if you can’t admin Cluster at this level. Hire someone competent (like us) or stop using it, because you are going to shoot yourself in the foot, bigtime.

Thank you. happy new year! D