Some grafics show "No datapoints"

Hi.
Like any other on this forum, i have a problem. I will be gratefull for any help about.
So…
After setting up pmm server, some grafics in Grafana show me “No datapoints”:

– mysql-innodb-metrics-advanced
---- InnoDB Log Buffer Performance
---- InnoDB Purge Performance
---- InnoDB Locking
---- InnoDB Main Thread Utilization
---- InnoDB Undo Space Usage
---- InnoDB Group Commit Batch Size
---- InnoDB AHI Maintenance
– mysql-overview
---- Process State
---- Top Process State Hourly
– mysql-query-response-time
---- Average Query Response Time
---- Read Query Responce Time Distribution
---- Write Query Responce Time Distribution

All other graphics related to mysql and linux work fine.

Is there some additional settings for mysql&pmm to make it work, or something else?

Some usefull info:

pmm-admin list:

pmm-admin 1.0.7

PMM Server | 111.111.111.111:81
Client Name | mysql.db
Client Address | 111.111.111.90
Service Manager | linux-systemd


SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS


mysql:queries mysql.db - YES root:@unix(/var/lib/mysql/mysql.sock) query_source=perfschema
linux:metrics mysql.db 42000 YES -
mysql:metrics mysql.db 42002 YES root:
@unix(/var/lib/mysql/mysql.sock)

Hi Aleksey,

can you please run command on mysql server?

PMM Network Status

Server Address | 111.111.111.111:81
Client Address | 111.111.111.90

  • System Time
    Server | 2017-01-26 13:17:33 +0200 EET
    Client | 2017-01-26 13:17:33 +0200 EET
    Time Drift | OK

  • Connection: Client --> Server


SERVER SERVICE STATUS


Consul API OK
Prometheus API OK
Query Analytics API OK

Connection duration | 577.096µs
Request duration | 987.613µs
Full round trip | 1.564709ms

  • Connection: Client <-- Server

SERVICE TYPE NAME REMOTE ENDPOINT STATUS HTTPS/TLS PASSWORD


linux:metrics mysql.db 111.111.111.90:42000 OK YES -
mysql:metrics mysql.db 111.111.111.90:42002 OK YES -

Did you get my answer? I cant see it…

Hi Aleksey,
I see your post, can you try to remove instance and add it again?


pmm-admin remove mysql
pmm-admin add mysql

Done. Nothing changed.

Looks like some options are not configured, please find all needed information in the following document:
https://www.percona.com/doc/percona-monitoring-and-management/conf-mysql.html

Thank you! Now it works :slight_smile: You were right, RTFM!!!