SMTP settings in pmm-server

Hi everyone,

I am trying to setup some alarms in the Dashboards. I just cannot figure out how to change the SMTP settings.
It is set to localhost but that does not work. So I want to change that to my email server.

Anyone know how to do that?

Andy

Hi Andy,

you can change config file.
documentation - http://docs.grafana.org/installation/configuration/#smtp
but please keep in mind that you lose your changes after docker image update

[smtp]
;enabled = false
;host = localhost:25
;user =
;password =
;cert_file =
;key_file =
;skip_verify = false
;from_address = admin@grafana.localhost

I had tried that. But changes in the file /etc/grafana/grafana.ini do not have any effect.

After changing the settings and restarting the services, the default values are still active.

So I assume, the actual config is overwritten from somewhere else.

Hi Andy,

Does your grafana.ini file’s SMTP section look something like what I posted below? Can you post it?

[smtp]
enabled = true
host = fqdn:port
user = myuser
password = mypass
cert_file =
key_file =
skip_verify = false
from_address = admin@grafana.localhost

Hi Andy,

I entered AWS SES smtp server credentials, everything is working fine.

my steps:

  1. run bash inside container
docker exec -it pmm-server /bin/bash
  1. open editor on /etc/grafana/grafana.ini file

[smtp]
enabled = true
host = email-smtp.us-east-1.amazonaws.com:25
user = SOME_ACCEESS_ID
password = SOME_SECRET_ID
;key_file =
;skip_verify = false
from_address = from-email@some-domain.com

  1. save changes and exit from containers bash
  2. restart container
docker restart pmm-server
  1. go to Grafana “login” page http://PMM.SERVER.IP/graph/login
  2. click “Sign up”
  3. enter another email and press “sign up” button
  4. find email in your mail client