slow_query_log_microseconds_timestamp=ON invalid?

I’m running 5.1.50-rel11.4 and my config file contains this line:

slow_query_log_microseconds_timestamp = ON

which I got from the docs, but but on startup the server says:

mysqld: 101105 9:19:52 [Warning] /usr/sbin/mysqld: ignoring option ‘–slow_query_log_microseconds_timestamp’ due to invalid value ‘ON’

What’s wrong with that? les.html

Variables that have a type of “boolean” can be set to 0, 1, ON or OFF. (If you set them on the command line or in an option file, use the numeric values.)

So try slow_query_log_microseconds_timestamp = 1