Setup Unsuccessful

Hello all-

I installed the Percona Backup from the repository yesterday on our test server. After I got it connected, I kept getting:

Error: unable to get config: get from db: get: mongo: no documents in result

when I do a pbm config --list

If I try setting:

pbm config --set storage.s3.bucket=“xxxxxx”

I get

Error: set config key: config doesn’t set

And finally, if I run this from the shell:


I get null as the result. So it’s apparent that the necessary collections didn’t get created. What am I doing wrong?



1 Like


This may be a bug - a usability bug, to categorize it - but a bug nonetheless. I suspect at the moment you ran pbm config --set storage.s3.bucket="xxxxxx" there is no storage.s3 subject of the config object so the attempt to set it fails due to a ‘reference to null’ type of error.

Is it the case that you hadn’t initialized the whole config with a “pbm config --file <yaml_file_path>” at the time?

1 Like

The instructions were confusing to me–they implied I could get a template first by using the config --list command, fill it in and then upload. I had originally tried uploading a file, but I am also unfamiliar with YAML and didn’t realize spacing was critical.

Thanks for your response, I figured it out and I’m running now.

1 Like

Oh yes, YAML is one of the white-space sensitive languages, like Python. Something to get caught on easily the first time.

We’ll stick with it though as using YAML files for config is required for MongoDB anyhow.

Thanks for sharing the update.



1 Like