read_only from command line not working

See [URL=“http://bugs.mysql.com/bug.php?id=58669"]http://bugs.mysql.com/bug.php?id=58669[/URL="http://bugs.mysql.com/bug.php?id=58669”];

The server ignores the read_only flag when it is provided in the my.cnf file. The variable READ_ONLY is displayed as ON, but it does not stop an insert from happening. If set it via “set global read_only=1;” it properly stops writes (but it does not work if it was set in my.cnf. I assume because it sees that it is already set, and does not set it properly).

I have confirmed that this is happening on percona 5.5.30-rel30.2

What should I do to make sure the slave is read only?

jt

Hi,

Can you please provide how you are setting variable in my.cnf? I have also tested the same on my laptop and it works fine with percona 5.5.30-rel30.2 version. I hope, you are not trying to insert with the user which has SUPER privilege. Can you provide the steps that how you are testing it? As per Doc,