Query cache not working

since my server goes very slow under a bit of load I tried to enable the query cache. I’m just running WordPress (PHP 5.1) + MySQL 4.1.10a and it’s a VPS (Virtual Private Server) on Virtuozzu with Suse Linux 9.3

Below are the MySQL server variables:

have query cache YES YESquery cache limit 1048576 1048576query cache min res unit 4096 4096query cache size 0 0query cache type ON ONquery cache wlock invalidate OFF OFFquery prealloc size 8192 8192
but the current status information just show:

Qcache free blocks 0 Qcache free memory 0 Qcache hits 0 Qcache inserts 0 Qcache lowmem prunes 0 Qcache not cached 0 Qcache queries in cache 0 Qcache total blocks 0

Did I miss a configuration value? There should be a lot of cacheable queries because the wordpress tables are rarely updated.

Best regards,


Oh, I’m sorry… I thought “query cache size” was the actual used size of the cache, not the maximum size. Works now )

Ok, Good you’ve found the problem )

Yes, sometimes it’s better to read the manual again instead of directly posting to a forum :o