pt-query-digest: Use of uninitialized value $types[0]

When running pt-query-digest on a certain type of database query, I receive the following error. If I run other types of queries, the error does not appear:

The pipeline caused an error: Pipeline process 4 (MySQLProtocolParser) caused an error: Use of uninitialized value $types[0] in hash element at /usr/local/bin/pt-query-digest line 4847, <$fh> line 5343.

Terminating pipeline because process 3 (MySQLProtocolParser) caused too many errors.

I have uploaded two pcaps to github, one with queries that pt-query-digest crashes on, and another from the same system with only queries that work fine. For context, this is a powerdns server. Queries that involve some combination of updating and reading the database are crashing it, while queries that only read from the database (no updates) seem to work fine.

Crashes pt-query-digest:

Works fine:

Additional info:

Tcpdump command used to collect data:

sudo tcpdump -s 65535 -x -nn -q -tttt -i ens33 tcp port 3306 > tcpdump.pcap

pt-query-digest command:

pt-query-digest --type tcpdump tcpdump.pcap --timeline --no-report

Hello @usafbeach 
I checked in with the team here. They believe it’s related to this Jira issue
If that’s the case, then it’s likely that it will be fixed for you in the next release, which should be within the next few days. If you want to be notified for sure, then the best thing to do would be to become a ‘watcher’ on that Jira issue, then you should get alerted to the fix. 
Hope this helps?

Hi @“lorraine.pocklington” ,
Thanks so much for the reply. I was aware of the previous JIRA issue you mentioned (in fact, I was one of the early commentators on this forum that pointed out it seemed to be related to the year, although I couldn’t figure out why - pt-query-digest: MySQLProtocolParser caused an error - #4 by usafbeach - Percona Toolkit - Percona Community Forum).
I do believe this may in fact be a different problem - I’ve tried setting my date back to 2019 (which was the trick I used before to overcome the issue in PT-1793), however I still get the same error results as above.

I’d  suggest to create a minimal pcap file which reproduces the problem and file the bug.