pt-osc with Amazon AWS RDS

I am trying to use pt-osc with an Amazon AWS RDS. I think the issue is similar to the topic in:

I have no issues using pt-osc on our main site implementation where we have Linux root and MySQL root access. However, we have another app that runs in an Amazon AWS environment. I have Percona Toolkit 2.2.8 installed on an EC2 instance and am trying to run the following command (I’ve substituted 2 character shortcuts for the sensitive stuff):

[ec2-user@nn ~]$ perl /home/percona/tools/pt-online-schema-change --alter ‘ENGINE=InnoDB’ D=aa,t=bb,,P=3306,u=dd,p=ee --execute --no-drop-old-table
DBD::mysql::db selectall_arrayref failed: Access denied; you need (at least one of) the REPLICATION SLAVE privilege(s) for this operation [for Statement “SHOW SLAVE HOSTS”] at /home/percona/tools/pt-online-schema-change line 4127.

I tried adding all privileges then missing privileges using MySQL GRANT, for example like below but it seems Amazon RDS doesn’t allow as implied in the post I referenced regarding pt-table-sync. However I have to believe there must be users who were able to get percona toolkit (e.g. pt-osc) to work in an AWS environment. What am I missing? I also tried explicitly adding “SUPER” in the GRANT but still get the same MySQL 1045 error.
GRANT ALL ON . TO ‘someuser’@‘somehost’;