PMM Upgrade to 1.7.1 OVA fails

Hello,
upgrade to 1.7.1 from 1.7.1 fails. Error message is attached. As this is the second time that happened (see in the forum) we wonder if maybe OVA isnt the best
variant and we should maybe switch to Container Version?
Kind Regards
– snip

  • echo 'CMD: /usr/bin/pmm-update ’
    CMD: /usr/bin/pmm-update
  • echo ‘PID: 794’
    PID: 794
  • echo ‘LOG: /srv/update/log/pmm-update__2019-03-12T09:56:04.log’
    LOG: /srv/update/log/pmm-update__2019-03-12T09:56:04.log
  • check_pid
    ++ basename /usr/bin/pmm-update
  • PID_FILE=/srv/update/pmm-update.pid
    ++ cat /srv/update/pmm-update.pid
  • PID=739
  • ‘[’ -n 739 ‘]’
    ++ ps -o cmd= 739
    ++ :
  • PID_CMD=
  • echo
  • grep /usr/bin/pmm-update
  • echo 794
  • main
  • local RPM_ROOT=
  • rpm --import /etc/pki/rpm-gpg/PERCONA-PACKAGING-KEY
    error: /etc/pki/rpm-gpg/PERCONA-PACKAGING-KEY: import read failed(2).

ok we solved it - might be helpful for other users
sign in to pmm via ssh (with the provided key)
run
yum update percona-release
the reason is explained here
https://www.percona.com/blog/2019/02/05/new-percona-package-signing-key-requires-update-on-rhel-and-centos/
upgrade works then!
kind regards

Outstanding. Thanks for posting solution:)