PMM Query Analytics for Mongodb not showing any querys

Hello,

I have just recently started up a PMM docker host and started to add my different clusters to the monitoring.

The server installation itself went smooth and after some fighting with different options on environment etc I got some sort of good result on my first testing cluster, I have a few that I want to add.

However when I moved on to the second cluster I am not able to see any query analytics even though it seems to be working ok for the first. I am not deeply familiar with this application and are looking for some type of simple mistake.

All my servers are running on:
OS:Ubuntu 20.04.2 LTS
Percona Mongodb: version v4.4.5-7.
PMMVersion: 2.17.0.

I have added a role to my mongodb cluster copying the settings from here: Enable mongodb query analytics
I also copied the create user command just to see if any small detail would help.

I connected the server with the “pmm-admin config” command and it showed up in pmm - great. And then I used the command “pmm-admin add mongodb” to add my host. It worked fine and now I could also see some more details in pmm home screen like db connections etc.

I added the exact config in the above link to the config file and restarted the cluster. I ran a very poor query to be sure I had something being fetched. When running db.system.profile.find() I can now see entries being logged. Therefore I guess the Profiling is indeed working. But I never see anything in PMM.

I have compared the following between my clusters:

  • pmm-admin list - identical
  • role -explainRole - Identical
  • users - my non-working cluster happens to have read all databases as well (I shall remove it but added it as a test.

Another difference I have found with my first and second cluster is that when opening the view called MongoDB ReplSet Summary the first cluster is displayed perfectly in ReplSet States. But the second cluster shows all of my nodes as primary servers. The rs.status() is good and the cluster seems to be well otherwise.

I would love some hints on where to look for errors or what else to compare between the clusters.

Hi @caritaRepo, welcome to the forums!

Regarding the second issue you mentioned, it will be fixed in the upcoming 2.18 release:

https://jira.percona.com/browse/PMM-7941

Regarding the QAN issues, can you check the PMM logs on the client side, for the node that is not showing any queries?

shell> sudo journalctl -u pmm-agent

Feel free to attach a file with these outputs over here, so we can check them. However, be mindful that the logs could contain sensitive/privileged information, that you may not want shared publicly!

2 Likes

Thank you @Agustin_G,

I will not put any effort into troubleshooting the second issue then. good input!

For the first issue I see a couple of errors - that is a progress in itself. I copied the result from the command- it is our test environment so I got a green light to share the logs. However just to be on the safe side I quickly replaced the server names I found.
someWhatModifiedJournal.txt (209.9 KB)

I am noticing an error stating "couldn’t send a block with size 19712 bytes to “1:secret-url”: Post “https://myNowHiddenDockerHost:443/victoriametrics/api/v1/write”: EOF; re->.

1 Like