PMM Installation : Docker Error starting userland proxy: listen tcp4 bind: address already in use

Trying to install PMM via wget -O - | /bin/bash but its throwing me below error…

docker: Error response from daemon: driver failed programming external connectivity on endpoint pmm-server (43e44262f35ab27fffee430197b20b00939b3c8e8193105bc6081b2724b1c3d2): Error starting userland proxy: listen tcp4 bind: address already in use.

Request you to please help.


Another service in your system is already using 443 port. Please find which one uses it and stop or use another port for PMM.

Hello Nurlan,

Thanks for the reply.

httpd is using the port 443. Can you please guide how to change the port for PPM?


Hi, here is a guide how to run docker container manually.

Here is docker documentation how to expose internal ports.

another option to try is

export PMM_PORT=8443
wget -O - 1 | /bin/bash

Thanks Nurlan.

With the help of the above command, i was able to install the PMM server.

After all the installation guide, below is the status…

PMM Server:
URL : https:// Server IP:8443/
Version: 2.41.2

PMM Client:
Connected : true
Time drift : -3.772658ms
Latency : 5.060662ms
Connection uptime: 93.8
pmm-admin version: 2.41.2
pmm-agent version: 2.41.2
/agent_id/ vmagent Running 42000
/agent_id/ node_exporter Running 420 01

Unfortunately, still I cant access the UI with the help of the access URL (the IP:8443).

Can you please help again to access the same.


Could you check if you are using https or http in URL?