PMM did not show any stats for my nodes ? why?


Hi,
Could you provide an output of the next command?
> pmm-admin status
Also please check states of Prometheus targets.
https://<PMM-server>/prometheus/targets


root@localhost bin]# pmm-admin status
Agent ID: /agent_id/74cb9920-48ac-466c-a11b-db76d1e981ce
Node ID : /node_id/bf56e2e5-ec35-483a-9325-1aeb5585c8b1

PMM Server:
    URL    : https://192.168.0.11:443/
    Version: 2.9.1

PMM Client:
    Connected        : true
    Time drift       : -106.125228ms
    Latency          : 422.421µs
    pmm-admin version: 2.9.1
    pmm-agent version: 2.9.1
Agents:
    /agent_id/3b119b83-c617-4e4d-a863-a181126c5a36 mysql_slowlog_agent Waiting
    /agent_id/436d2cba-7748-4812-9d6f-8f5ad30d6205 mysqld_exporter Running
    /agent_id/574a892b-ec33-479a-81b0-e8922a59110f mysqld_exporter Running
    /agent_id/8b208991-4aa1-474b-89c1-010ca4ef458b mysql_slowlog_agent Waiting
    /agent_id/f2d86cfa-f922-4d53-9ea0-474c5427539e node_exporter Running


Have you got any errors in Prometheus for targets?

yes, Status shows down for the node?


adivinho

How to resolve it ?
 

the node was added with a positional element as “node” which is not resolving in your DNS.  Can you post the command you used to connect the client to the server?  It would appear the command would be something along the lines of:
pmm-admin config --server-insecure-tls --server-url=https://username:password@pmm-server/ node
the presence of that “node” at the end of the line actually overwrites the auto-detected node-address (typically the first IP found on the system) with whatever you put and if it’s a name vs IP will attempt to resolve that name to reach back out to the client that needs to be monitored.  use ‘pmm-admin config --help’ to see the options as well as the auto-detected defaults we’d use for the positional elements.

easiest way to clean it up is to use the PMM Settings page --> PMM Inventory and force delete the node from the server and re-configure from the client (‘pmm-admin config’ as well as ‘pmm-admin add’)

pmm-admin config --server-insecure-tls --server-url=https://admin:lokesh123@192.168.0.11/ node --force


still no data shows on graph for node???


Checking local pmm-agent status…
pmm-agent is running.
Registering pmm-agent on PMM Server…
Registered.
Configuration file /usr/local/percona/pmm2/config/pmm-agent.yaml updated.
Reloading pmm-agent configuration…
Configuration reloaded.
Checking local pmm-agent status…
pmm-agent is running.



are you trying to name the endpoint “node” so it displays that way in PMM?  
Give this a shot:
Remove the node from pmm-server using the UI’s inventory page (PMM --> PMM Inventory, click on Nodes tab, check the box next to your “node” node and delete, use the “force” mode checkbox to ensure all services and agennts are removed as well)
Re-register the node from the PMM server using the following format:
pmm-admin config --server-insecure-tls --server-url=https://admin:lokesh123@192.168.0.11/ <ip address of host*> generic <whatever you want to show up as the friendly name>
*you can also use fully qualified domain name that your pmm server can resolve with DNS
That will register the PMM client to the server but in order for the server to actually pull stats it needs to be able to make a TCP connection back to the client.  So far you’ve only enabled the node exporter which after about 60 seconds will populate the system stats on the main page, you can next add a DB exporter (pmm-admin add mysql --help) and it will then start gathering mysql metrics.  if it’s still not working see if there’s any errors on https://192.168.0.11/prometheus/targets and post.  

Thanks @steve.hoffman