Pmm client installation failing

Hi there! I am trying to install pmm client on my ubuntu 20.04 VM , but I am getting this following error.
Any fixes?

sudo dpkg -i percona-release_latest.$(lsb_release -sc)_all.deb

(Reading database … 97443 files and directories currently installed.)

Preparing to unpack percona-release_latest.focal_all.deb …

Unpacking percona-release (1.0-27.generic) over (1.0-27.generic) …

Setting up percona-release (1.0-27.generic) …

Specified repository does not exist: Percona Repo

Specified repository does not exist: Percona Repo

The percona-release package now contains a percona-release script that can enable additional repositories for our newer products.

For example, to enable the Percona Server 8.0 repository use:

percona-release setup ps80

Note: To avoid conflicts with older product versions, the percona-release setup command may disable our original repository for some products.

For more information, please visit:

Now when i run ,

sudo percona-release setup ps80

Specified repository does not exist: Percona Repo

Also,

sudo apt install -y pmm2-client
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package pmm2-client

Thank you

Hi Sanjana,

Could you disable and re-enable the repository?

percona-release disable all
percona-release enable original release
apt update
apt install -y pmm2-client

Still the same ,
sudo percona-release disable all

Verification code:

<*> All done!

==> Please run “apt-get update” to apply changes

sudo percona-release enable original release

Specified repository does not exist: Percona Repo

I even ran apy-get update after sudo percona-release disable all

Any help? Please help me with this, i am unable to proceed further.

Thank you

It looks like you have got issues with DNS in your VM.
Could you exec the next command?

ping repo.percona.com

Yeah, the url is not ping-able.
ping repo.percona.com

PING us.r53.percona.com (149.56.23.204) 56(84) bytes of data.

us.r53.percona.com ping statistics —

19 packets transmitted, 0 received, 100% packet loss, time 18408ms