Pmm agent not found

I have tried installing pmm client on my server. I followed the package method. Specifically the binary package. I did installed the client successfully. also, added my mariadb server hostname(ip) to the server. I was able to see the mariadb server in the PMM monitoring system. I have the urs/local/config/ in my mariadb where the client was installed , which means the client was successfully installed.

Whenever I did pmm-admin status I always get pmm -admin command not found. Even I did tried to readd the server again by doing this = pmm-agent – setup – config-file=/local …
I still got PMM agent not found.
anything I did with pmm I got PMM not found.
Can someone just help out

1 Like

Hi @Dba1 thanks for posting to the Percona forums!

If you did installation using binary, that usually means you downloaded a tar.gz, and you copied the files into a set of directories manually. Probably pmm-admin didn’t get added to your $PATH. You can reference it with the full path /usr/local/bin/pmm-admin (or wherever you installed the files).

Please let me know if you in fact used a deb / rpm installation method.

1 Like

Thanks Michael these are my steps after download ( tar xfz pmm2-client-2.33.0.tar.gz &&pmm2-client-2.33.0)

  1. export PMM_DIR=/usr/local/percona/pmm2
  2. ./install_tarball
    4.pmm-agent setup - - config-file=/usr/local/percona/pmm2/config/PMM-agent.yaml - - server-address =xxxxxx - - server-insecure - tls ……. Yari yari .

Even with the monitoring system seeing my mariadb server in the GUI. I still have issues with PMM.
I have tried my best. Left it came back to it many times still having issues

1 Like

Thanks for the detail @Dba1

I have never in fact tried to do the installation using the tarball method… so these are more guesses:

  • It looks like you used upper-case for the configuration file. it should be /usr/local/percona/pmm2/config/pmm-agent.yaml
  • I generally use the syntax pmm-admin config ... to do the configuration and not pmm-agent setup, I suggest you try this method
  • Can you try using the full path when calling pmm-admin such as /usr/local/percona/pmm2/bin/pmm-admin add mysql ...
    Let us know how you make out with these suggestions! If these fail may I suggest you try with one of the deb or rpm options as they have consistently worked for me and I expect you will have the same success!
1 Like